LibreOffice-created doc, xls, docx, xlsx won't open with Microsoft Office

Whenever I save LibreOffice documents as .doc, .xls, .docx, .xlsx (these are the only ones I’ve tried), Microsoft Office 2007/2010 can’t open them. They are seen as corrupted document files and I’m asked by MS Office to use its open-and-repair function, which fails nonetheless. In fact, MS Office is able to repair and open .odt and .ods documents, unlike its aforementioned seemingly native formats.

If I may, what’s the point of being able to “Save as…” if the respective formats can’t be read by their native suites (i.e., MS Word, MS Excel etc.)?

I’m currently using the latest LibreOffice (v in Ubuntu 12.04 LTS. I’ve tried this on multiple Ubuntu (11.10/12.04) and Windows (7) computers.

Thanks for the help, in advance.


Thanks for including such specific information in your question. I don’t have machines running those specific versions of Ubuntu, Windows, and LO, but I’m going to put that information into a new bug report and see if we can find someone else with a similar configuration to see if they can reproduce your problem.

The bug report is here:

To help us troubleshoot what’s going wrong, could you please upload an example file or two (perhaps doc + xls) that you’ve saved from within LO to that bug? That will make it easier for us to troubleshoot the LO export and the MS-Office import as two separate steps. Thanks!

Hmm. Was there a change in the LibreOffice 3.5.x Microsoft DOC export filter? might be related.

Temporary Fix: You could try installing the PPA version of LibreOffice by following the instructions on the Ubuntu page here:

It looks like that will get you to at least 3.5.4, although no guarantees that the problem will be fixed. As usual, the software in the PPA is for testing and isn’t officially supported like the regular Ubuntu packages. But it might be a good short-term band-aid.