LibreOffice don't open after update to 7.2.2 (Window 10)

Hi. I had Libre office ver. 7.0 and last night downloaded the update to 7.2 (?). Today, I have ‘no’ openable, working Libre office program - not one part of it is functioning. Help please if you can or direct me. Thx.

Which one exactly? 7.2.1? 7.2.2? Which platform? Windows?

1 Like

If your problem is that LibreOffice does not start at all, launch it from the command line with libreoffice --safe-mode or use the start menu entry LibreOffice (Safe Mode) on Windows

Select Continue in Safe Mode
If LibreOffice opens OK then click Tools > Options > LibreOffice > View and untick Use Skia for all rendering. OK out and try starting LibreOffice normally.

BTW. The title should reflect the contents. Your title looks like a question about the askLibreOffice site, as a result fewer people might look at it. Very much hit and miss

2 Likes

Hi, it’s 7.2.2 This machine is running windows 10.

Edited the title.

1 Like

I appreciate the ‘how to’ meat in your helpful offer. Regarding my post’s title opinion, I don’t understand your take is what I’m thinking… I plainly wrote " LibreOffice don’t open ". I did not write “askLibreOffice site”. Honestly Al, what am I missing ?

So, LibreOffice will ‘not’ open in safe mode. I’ve long forgotten how to use the command line stuff, so if you have suggestions in that regard, please be explicit and illustrative. I have to add that I notice that both shortcut iterations show up in my programs menu: both LibreOffice 7.0 and 7.2.2 (whatever the newest is). Might I need to delete one or both ? Perhaps a corrupt download ?

The initial subject was

Help,Libre how to’s beyond Forum hit and miss

1 Like

Not you; @LeroyG wrote it, replacing the original title (now he don’t remember it).

I think from what you have written, that you have already tried Start menu > LibreOffice 7.2 > LibreOffice (Safe mode). If you haven’t, try it, click Continue in Safe mode, when LO opens click Tools > Options > LibreOffice > View and untick Use Skia for all rendering. OK out and try starting LibreOffice normally.

You shouldn’t have LibreOffice 7.0 in the Start menu any more. There might have been error messages at the time you were installing.

I would suggest

  1. Turn off your anti-virus temporarily
  2. Click Start menu > Windows System > Control Panel > Programs & Features, scroll down until you find LibreOffice 7.2.2.x (x is for the last digit you haven’t told us). Right click it and select Repair
  3. When complete, Restart Windows (NOT Power Off, the default for that is hibernate) and see if LO starts normally. If it doesn’t try Safe Mode and steps at start of this comment.

See General Installation Issues (Windows) - The Document Foundation Wiki for some more information.

If you still have trouble, please say what anti-virus you are using.

1 Like

EarnestAl, The only thing I’m using for anti virus is the ‘Windows Defender’. You are correct, I’ve tried the methods w/o shutting off Win Defender. I would add that I actually had issues after downloading Version 7.0 to begin with some time ago. Most all my document and picture files got scrambled about, some not found to this day. Upon opening what were formerly win doc, docx, and PDF files, I’d get a message box alert that stated 3 separate document files were not ‘recovered’. (?) All this began when I needed alternative word processor and office programs to Microsoft’s. I had faithfully re-purchased successive MS products every few years up to 2015-16 versions of MS office. A corrupt download trashed the entire system. A remote tech I hired backed up data, but not programs and reinstalled. With no records to back up my claims, MS wouldn’t support. Hence my migration to Libre. Thx for your help. ~DN

There is a lot to unpack there; corrupt download, files not recovered, remote tech re-installed Windows.

I might be inclined to start with scanning the hard drive for corruption/bad sectors and work up from there.

I presume you have set LibreOffice as an allowed program in Windows Defender? Click the conveniently located Start menu > Settings > Update & Security > Windows Security > App and Browser control > Virus and threat protection > Virus and threat protection settings > Controlled Folder Access > Manage controlled folder access > Allow an app through controlled folder access > Add an allowed app > Recently blocked apps and see if soffice.bin is in the blocked list. If it is allow it by clicking on the plus next to it. and, if I recall correctly, click the button Allow .

1 Like

lol, I’m pretty new to using this method / forum style to solve problems. I never had the luxury of the time to become as digitally adept as many folks. For me, the computer is a useful tool that I did not craft nor get under the hood of, so to speak. Is what it is…

LibreOffice 7.1.6 is available.

The installed version is LibreOffice 7.0.6.2 Yesterday I also upgraded and it would not start. After trying a few things I gave up reinstalled the older version and is now all fine. May I suggest that their is a fault with the latest update.

@ian4bs a quick search in the search box using the term 7.1.6.2 would have found solutions to you problem rather than hijacking this thread.
In any event, if you click Tools > Options > LibreOffice > View and untick Use Skia for all rendering in your current version, you can then update to 7.1.6.2.
It is bug tdf#144434. Uninstall 7.1.6.2. Reinstall your earlier version (the archive has copies of previous versions but 7.1.5.2 should work fine).

2 Likes

@ian4bs, I also had a similar issue after updating [Windows 7]. I downloaded 7.1.7.1, and that version worked for me.