M1 MacOS Monterrey 12.2.1 + java SE 17 + Libreoffice 7.3.0.3 not using the java installed

I have installed SE 17, reboot the Mac, still same behavior. I installed SE 8, same. When I enter Preferences → Advanced java is clicked, it says it is installed but not working.
I am trying to export 2M rows from LibreOffice Base to CSV and looking for options to do it. I do not know if I need java coz new to LibreOffice and exploring.

How to install Java (JRE/JDK) so that LibreOffice could use it?

@Hrbrgr thanks. None of them available any more. I use Oracle SE 17 and Adopt 16. Same behavior, box checked, it says it is installed, do not recognize any version and when I try to add by hand the any folder ending …/Home it says “The folder you selected does not contain a Java runtime environment” I tried exporting JAVA_HOME variable in terminal and start Libreoffice and same thing. Sounds this program does not use JAVA_HOME? I had java issues in the past but used to solve using /usr/libexec/java_home -V and use the path displayed by command. Now I have these ones installed

MacOS % /usr/libexec/java_home -V
Matching Java Virtual Machines (4):
17.0.2 (x86_64) “Oracle Corporation” - “Java SE 17.0.2” /Library/Java/JavaVirtualMachines/jdk-17.0.2.jdk/Contents/Home
16.0.2 (x86_64) “Eclipse Temurin” - “Eclipse Temurin 16” /Library/Java/JavaVirtualMachines/temurin-16.jdk/Contents/Home
1.8.321.07 (x86_64) “Oracle Corporation” - “Java” /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home
1.8.0_311 (x86_64) “Oracle Corporation” - “Java SE 8” /Library/Java/JavaVirtualMachines/jdk1.8.0_311.jdk/Contents/Home
/Library/Java/JavaVirtualMachines/jdk-17.0.2.jdk/Contents/Home
MacOS %

Is there any way to read a debugging? a log? to see what is going on?

Sorry, I use Windows myself and hope someone else will help you out.
Or search the search bar above by keyword for more answers on your topic.

Another way to install LO in M1 Macs. Download LO M1 installer but do not install intel java installers. Until today the only one I have found is Azul java for M1.

If you want to check LO running, go to Activity Monitor in Mac and inspect Kind column. If it says intel, it is running as intel code. If it says Apple, it is running as M1.

I solved the issue. I have an M1 in iMac. I downloaded it but Libreoffice does not work with java.
I erased the LO M1 version and downloaded the intel version. It works. When I go to Preferencies/Advanced I can see all the java versions I have installed :laughing:
So in brief I downloaded the intel Mac version in my M1 iMac device and it works.

1 Like