Mdb files not loading to base

Confirming @Regina comment. My Windows is old 32 bit with LO5.3.x & Java all being 32-bit. Access connection works fine. Just need the proper location of the .mdb.

how run a v5 32 bit system Error 1 is fix how but error 2 is the same on this version also

@taybee Sorry I missed that point. You cannot open an .mdb file directly in LO. You can only connect to it through Base and then only for tables & queries. Forms & macros are non-transferable.

@ratslinger thanks for your help and the info on Base
will close this off how

Your welcome & thanks to @Regina. @taybee if you want to close there is selection ( Xclose) lower right of your question. Then you can select reason in dropdown.

Hello, @taybee,

I have re-opened this question because I have discovered a way to connect LO Base 64-bit with Access in Windows 10 (guessing other versions should work).

Not having used Windows for years (with rare exception to test on an old 32-bit system) I never got to test this process. Was able to do so on a Win 10 Home 64-bit system using LO v5.3.x 64-bit.

On my Linux Mint18.3 system I use a connector UCanAccess (website here) to connect to Access DB’s. Turns out this same connector works on Windows 10 also. Although stated as so, have not personally tried with LO until now. Have tested with UCanAccess v4.0.3 and v3.0.4 and both work.

First download and unzip the connector files into a folder. Now open any LO file & go to Tools->Options then LibreOffice->Advanced. Select Class Path button then Add Archive button. Then point to the ucanload.jar file in the unzipped download files. It is in the loader sub-directory. Then Open button. Class path will look similar to:

image description

depending upon where you actually put the unzipped files, Then select OK button.

Next you need to add a parameter. Still on the Advanced page, select the Parameters... button. There, in the Java start parameter line enter -DUCANACCESS_HOME=C:\YOUR_FOLDER_LOCATION\UCanAccess-4.0.3-bin then click the ADD button with a result similar to:

image description

Now you are ready to create a connection to the Access file from Base. Open Base & select Connect to an existing database with the dropdown selection at JDBC then click Next. In the Datasource URL enter (after pre-existing jdbc:) ucanaccess://C:\YOUR_ACCESS_FILE_LOCATION. In JDBC driver class: enter net.ucanaccess.jdbc.UcanloadDriver. Test Class button should result in successful driver load. If error, recheck Class Path setting in Advanced. Click Next button. Can test connection here. If error, check for proper file location (note: // before file location is important).

image description

Above screen is slightly different because it was taken directly from the Base file. Entries are the same. Click Finish button and save.

Your tables should now be accessible.

1 Like

I have spent all day following these instructions (and correcting the wrong entries of my fat fingers), and I have succeeded in opening one of my old databases in LO at last, so the instructions do work. However, in spite of entering its location into ‘Datasource URL’, whenever I try to access the database I really need to be able to get at, I am told that it does not exist. I must be doing something silly. What can it be?

@chrisg Is it possible the database you can’t access is not one of those supported as mentioned on the website:

  Supported Access formats: 2000, 2003, 2007, 2010.

This copied from first line under ‘Features:’

I think the problem lies right at the end. When one pushes ‘Finish’ you are asked to save the file. The only option is to save it as an .odb file (which already exists). If I select this option, and to overwrite the existing file, I am told it cannot be written. So what now?
The earlier database which worked is, as far as I know,of the same vintage. Both are .mdb files. The one that does not work was in fact created by copying the earlier one. How does one tell which version the file is?

Not sure what you are attempting. Understand I am currently testing with Linux Mint as only had short access to Win system.

Have Access2000 mdb. Copied it. Created new Base file to access copied mdb. Entered all setup info using copied mdb. On ‘Finish’ selected old odb & had it overwrite it. No Problem. Newly overwritten odb now accesses the copied mdb.

Also tried just modifying the existing odb to point to different mdb using Edit->Database->Properties... and again no problem.

BTW I don’t believe there is any easy way to tell the version just from the file. It seems you need Access or some other tools from MS. Since this is for Windows it is outside of my realm. Have tried to use Wine on Linux several times but never any success getting programs to install and run.

Tried again. I can now open the file. When I try to open tables, I get a message saying that warnings were encountered, to the extent that the user either lacks privilege or the file (whose name starts @@ end includes REFS3 - which I did not think was involved), but when I press OK, I can then open the tables, but no queries or reports are visible. I guess I can update the tables but not make use of the report which I need.

Sorry, I should have added that I have now updated LO to 5.4.5.1 x64

Also have 5.4.5.1 installed. Table warnings can be the result of many things. If you mean Access queries & reports, it has always been the case that only Tables and possibly queries (don’t know exact circumstances) are accessible. Forms and Reports originally created in Access are not. Reading back over the original question (December 2017) I see some references to REFS3. But exactly what you have and what you have done to date is sketchy. Queries, reports, which odb has what?

@chrisg Start a new question with what your current problems are. Include all the dealings & procedures you have gone through thus far. This post was actually created by someone else & has been answered.

@Ratslinger - How is it possible that this incredibly detailed “how-to” has only one (1) upvote (mine!)??? This is brilliant. It deserves a medal, not a “badge”! :slight_smile: Thank you!

@dajare Thank you for the comment & support. I certainly would not use terms like ‘brilliant’ or ‘deserves a medal’ as, in fact, I discovered this product years ago when needing something for Linux. Like so many other answers presented in ANY forum, most of the questions presented have have already been answered somewhere. It simply requires a little effort (or in a couple of cases a year or two) to fit things together.

Do these instructions work for Mac OS? I do not have the option of Tools - Options and get stuck at that point.

@bammbamm401 Tools>Options menu selection on Mac is LibreOffice>Preferences. However the above is specifically for Windows 10. Have also done with Linux but personally have not tried Mac OS (no access to one). From some basic searching, it seems it should work. Here is the website → UCanAccess. There is an active discussion section there which should be able to help if needed.

When I test connection in the set up user authentication I get an error of UCAExc:::4.0.4 null. I have checked the class path and the parameters and they are both the correct paths. I know this is an old question and I hope someone see this and knows what is up in my case.