Paste copied cell-content to multiple cells does not work anymore

Hello all,

I have been an LO-calc user ever since and it mostly worked as expected.

But since yesterday, copying the contents of a cell to multiple cells does not work anymore: I can not paste anymore a formula, text or whatsoever from one cell down to multiple other cells in one operation.

I can copy one cell to one other cell. But I can NOT copy one cell to a number of cells, neither horizontally nor vertically nor both at a time.

This stays the same if I completely shut down my computer and restart it, then only open libroffice and nothing else. And it makes no difference if I have the KDE-clipboard enabled or not.

The update history shows that the last update of libreoffice was in April 16th 2021. Since then, there was no problem, it just happened yesterday after an import from a csv file. The csv file was saved and then, libreoffice was completely closed. When I later opened a new, empty sheet, I hit this problem.

Is this a known issue/effect/behavior?
How can I get back to normal operation?

A final note: If I try with “Inhalte einfügen …” (in english, “Paste Special …” I guess) from the edit menu, a small dialog pops up, telling “Unknown source” and just offers “unformatted text”. But even then, nothing is copied. The same happens with ctrl-shift-v.

Any help is very much appreciated.


See my OS/LO versions below:

OS: Linux 5.11.0-41-generic #45~20.04.1-Ubuntu x86_64
KDE Plasma Version: 5.18.5
KDE Framework Version: 5.68.0
LO Version:
Build-ID: 1:6.4.7-0ubuntu0.20.04.2
CPU-Threads: 8; BS: Linux 5.11; UI-Render: Standard; VCL: kf5;
Locale de-DE (en_US.UTF-8)


I have removed the entire libreoffice-configuartion including my complete user profile. After starting libroffice, a new default configuration was created by libreoffice.

But the problem still persists.

Thank you.

Here is what I did:

Uncheck Tools ▸ Options… ▸ LibreOffice ▸ OpenCL ▸ Allow use of OpenCL.
Restart LibreOffice, check if issue still occurs.

Didn’t help, almost same result (see below)

If it does, uncheck Tools ▸ Options… ▸ LibreOffice ▸ OpenCL ▸ Allow use of Software Interpreter (even when OpenCL is not available).
I don’t have this option in the dialog.

Regarding the “almost” above: I now get a Paste Special dialog which is populated with the common options. And it does copy something, but not what I want: There are no formulas in the cells, but just the computated values.

I wonder anyway, why things fail all of a sudden: I haven’t changed something to my best knowledge. Yes, some packages change or get added, updated or removed from to the system every now and then, that’s normal on a developer machine. But nothing related to office or libreoffice.

I have been an IT-professional since decades (C++ & Linux world) and would for sure tell if I’d have a suspect. But I am really clueless.

If you weren’t a dev, I’d suggest re-installing LO. But of course I know this is a matter of curiosity.

Have you tried writing a macro that uses the Dispatcher or clipboard service to do the clipboard manipulation? A starting place might be this one, which I keep in my library, and is credited in the comments:

Function getClipboardText() As String
    'Returns a string of the current clipboard text
    'From Frieder Delor

    Dim oClip As Object '
    Dim oConverter As Object '
    Dim oClipContents As Object
    Dim oTypes As Object
    Dim i%

    oClip = createUnoService("")
    oConverter = createUnoService("")
    On Error Resume Next
    oClipContents = oClip.getContents
    oTypes = oClipContents.getTransferDataFlavors

    For i = LBound(oTypes) To UBound(oTypes)
        If oTypes(i).MimeType = "text/plain;charset=utf-16" Then
            Exit For
        End If

    If (i >= 0) Then
        On Error Resume Next
        getClipboardText = oConverter.convertToSimpleType _
    End If

End Function ' getClipboardText

Are you sure you don’t have a clipboard “manager” (aka destroyer) in use? Because such failures are usually related to some dumb clipboard software messing around.

Thank you for your help. :slight_smile:

Just for the records: Yes, I have considered to reinstall libroffice completely. A typical windows solution, I guess: “Buy a new computer and move to a different City in a different country” :-((
But as things stand, it is simply too epensive to waste my time with tinkering around. Especially in face of (apparently) tons of “cut & paste” issues in libreoffice and there is seemingly no concept of tracking and precisely eliminating such ever-dangling problems.
For the time being, I am currently restoring my ~/.config/libreoffice folder to see, whether this helps.
I do not yet know what your code snippet does, but I will try this out. Thank you a lot!


Are you sure you don’t have a clipboard “manager” (aka destroyer) in use?

Well, I am. But even as a developer it is not always clear to me, which levels and instances of keyboard and clipboard processing I am facing in nowadays systems.
Currently, I am working remote for a customer via citrix, VNC and other layers on a remote linux development machine. However, my libreoffice problem is local, on my own machine.
BUT: this crappy citrix BS is intruding deeply into keyboard and cut & paste stuff to prevent ‘evil developers’ from cutting and pasting things from the remote site to the local site and vice versus - which is ridiculous, as I can do that if I want with and without citrix. There are other ways to do this if I would like to. But to make this short: yes, there is some uncertaincy about this. But the problem popped up all of a sudden, and didn’t show up all the months before - when citrix was already there.
But I can anyways assure that the problem persists after a cold reboot even before any remote session was started - and there is for sure no citrix stuff active at this time.
For your interest, I have appended my current jobs-list, with citrix and my remote session being active. Perhaps you can find something suspicious.

jobs.odt (26.4 KB)

This happens when do you copy text from within a cell or from the input line, or unformatted text (i.e., from a text editor). It will be pasted only in the first cell of the selected range.

As a workaround:
Paste in the first cell, copy, select the range, and paste.
Select the range, paste, edit the cell (F2), add and delete a space, Alt+Enter.

LibreOffice, on Linux 4.12.

1 Like

Except for the first paste this is exactly what doesn’t work. I just tried with this first paste, same result.

I am not sure whether I understood this right, but i tried and no success. Besides this, this is not the regular “copy a cell, mark a range, paste” workflow and more a rape of normal work.
Nor does it address the fact, that things worked before but do not anymore work now. There is something unclearified here, and to me, this seems to be one more candidate in the LO-hall-of-faults of copy&paste.

That’s funny (not), you mention “crappy citrix BS is intruding deeply into keyboard and cut & paste stuff” and at the same time want to nail the clipboard failure on LibreOffice being at fault.

As I had mentioned, it all worked flawlessly since months, with citrix running at the same time together with Libreoffice. And if you read carefully, I as well mentioned that the same problem now occurs in any combination, with citrix and without citrix running at all.
I don’t by the way think, that getting personal is any help.
But nice you’re amused.

Please, can you attach a sample file, with a step by step about what doesn’t work.

See attached file. Instructions inside.
CopyAndPasteFail.ods (12.8 KB)

1 Like

Well, turns out it works perfectly for, whether pasting one at a time or pasting the entire range. BTW @mariosv: Great setup on the example sheet!

Tried connecting by Remote Desktop Protocol (rdp) to Ubuntu 20.04, LO The problem is not reproducible.

Thanks all for trying. However, my version is Currently, there is no official update in the repository.
With respect to the fact, that this worked without problems all the time until the problem popped up, I am afraid, it will be hard to reproduce. The example-sheet is extra simple, nothing special. But no success.
Next weekend, I will reinstall LO completely if no other solution is found.

So I tried a number of steps in the meantime (all carried out with the corresponding linux ‘apt’ commands):

  • reinstall calc
  • purge calc & install calc
  • reinstall libreoffice*
  • purge libreoffice* packages completly and reinstall
    None of which helped: libreoffice calc does not copy & paste, just the same as explained before.
    The weird thing is, that this started to fail in the middle of nowhere. There was no update/upgrade/install/remove of any package in the meantime, nor did I change something in libreoffice (why should I?).
  • Are any developers of the affected libreoffice-functions watching this?
  • Is there any hope to get a fix?

Does dragging the range with the mouse work?

Maybe not. To contact developers, we need to go to

Have you tried pasting from the menu Edit? Pasting only formulas?
What if do you paste in the first empty cell, then select the following cells and Repeat (Ctrl+Shift+Y)?

Yes, I had tried all the options you mentioned - without success…
However, I have now found the culprit. Maybe.
After the installation of libreoffice from a ppa (which I really hate), the error was still there. So I looked in many other corners and finally found the problem - though there is still some mystery.
I clicked on the configuration of the plasma ‘clipboard’ widget. There, I tried with the options marked in the screenshot. After disabling them, things worked as they should.


However, after stopping calc, re-enabling the options, and restarting calc again, it still worked as it should.
:frowning: :frowning:
So for the time being, I am happy it works. But I have lost a lot of confidence in libreoffice, and I am really asking myself, why such a simple solution seems to be unknown elsewhere.
Perhaps because this isn’t really a solution, who knows …