Setting page header for endnote pages?

I am creating a journal with several articles, each with their own endnotes, so each article has been set up as a section with Format - Sections - Options - Footnotes/Endnotes tab - “Collect at end of section” ticked.

The page header has been set to the “Chapter name” variable, so that the pages in each article have its title at the top of each page.

However, if the endnotes extend over several pages then the header for the second and subsequent pages of endnotes is not the article name, but instead says “Contents” (I have a Table of Contents at the front of the journal).

I think that the problem stems from the fact that the endnotes for each article fall OUTSIDE the article section - but I cannot find a workaround.

Any ideas, please?


endnote bug master.odm



master document

– I took the liberty to patch the question because you messed something when uploading – ajlittoz

EDIT 1 2019-09-01

Sample file for bug report: endnote bug all in one.odt

endnote bug all in one v2.odt

EDIT 2 by ajlittoz

Worked out file for bug report with coloured backgrounds to show section boundaries EndNotesBug.odt

I can’t reproduce under Fedora Linux 30, LO

When endnotes are not within a section, endnotes are laid out in Endnote page style (from the first note page) which would explain why header/footer is different from article page. There is no such page change when notes are in a section.

Please attach a short sample to your question (edit it to be able to do that, you can’t attach to a comment) so that we can have a look at it. While you’re editing, mention your OS and LO version.

Thanks. I have prepared a small sample (one .odm and 3 .odts). Since it won’t let me upload file type .zip, I have renamed the .zip file as a .tiff … I hope that this will unpack when you rename it … :-).
I am running on Win7 Pro SP1, LO


…you say “when notes are in a section” … how can I get the endnotes INTO the section.please? … they automatically seem to be beyond the end of the article section?



how can I get the endnotes INTO the section.please?

Quite straightforward: tick the Collect at end of section box. You say you did it, that’s why I want to have a look at your document. Since you mention an odm, the problem may occur when assembling master and smave documents together.

But having done “collect at end of section”, the endnotes are actually beyond the end of the section. If I put the cursor at the start of the document, and hit Ctrl-End, it highlights all of the article text, but stops short of the endnotes. Sorry - I thought that I had I implied a master document, but should have made it explicit … :-(.

…sorry - that should be Ctrl-Shift-End …

Still waiting for the sample file. Did you fail when attaching?

Sorry - my subterfuge of renaming the zip seems not to have worked! I have now attached the .odm and 3 .odt files …

From preliminary analysis, this misbehaviour is related to master/slave architecture. Investigating.

OK - thanks - sorry about the mix-up in uploading …

Very confusing. I think there is either a bug in Writer or a non-anticipated short sight during conception.

Your document is split between a master document and slave ones. The basic principle is: master document settings override those of the slave documents. That’s worth for styles, but situation seems a bit more complex with sections.

You configured the sections in the article documents with the Collect at end of section ticked. However, since your articles are alone in the documents, this is not important for the article document apart from the fact it causes no page style switch.

First, I used all your files as is and I incur the same “bug”. I then unticked the Collect box in one of the articles and the corresponding end notes jump to end of the master in an Endnote page. This can be considered as “standard”.

Thinking that the section definition was faulty or not correctly interpreted, I created sections in the master and tried to link the articles from the sections. Writer refuses to insert links to other files from a section! The to-be-inserted article was put at the start of the document instead, outside any section.

Whatever I do, the inserted document is formatted within its pages with the expected header until we reach a page full only with notes. There, header reverts to the first Header 1 found in the document. To make it clear, it is not the one preceding the article with the faulty notes, but the very first in the document.

To summarise:

  • it is impossible to insert a slave document in a section. To the best of my knowledge, this constraint is not mentioned in the documentation.

  • End notes are not managed correctly when collected in the master document. Page management is totally messed up, Writer, seemingly loses its position reference.

IMHO, this a bug. File a report at Try to reduce even more the sample. A single slave document should be enough. Add two or more Heading 1 at head of master to clearly show which “chapter title” is selected in the header.

PS: You seem to type your document like was taught during typewriter era: two spaces after period. This is no longer recommended nowadays because it can cause problems when justification is enabled. I know some prefer a wider space after a full stop, but this should not be done like that. Maybe a change in end of sentence handling within Writer might be desirable.

Also, most of your documents are styled Default Style instead of Body Text. Default Style should only be used to set defaults (no pun intended) for all other styles because all its attributes propagate to all others (unless overridden of course). This is a handy trick to change everything in a document.

#Bug report created 2019-09-01

See tdf#127264

It appears this is a duplicate for bug tdf#123917 issued 2019-03-07

Thanks. It’s good to know it’s not just me … :-)! Will produce a simpler example and submit a bug report.

As for your comments - yes, I do tend to prefer two spaces after the full stop, and hardly ever used justified. As for Default Style, I used that for simplicitym, but for my real document I have used my own body text style.

The problem is nothing to do with master/slave and is far more fundamental in the handling of endnotes. While simplifying for a bug report, I have created the simple file endnote bug all in one.odt which shows the problem - attached.

Where is the attachment? Due to AskBot limitation, you can attach a file only to a question, not to a comment.

I thought that I had added it to the original question … have just tried again.

Sorry - I think I have spotted what I have been doing wrong - after adding the attachment I need to press the “Save” button below the question … which is off the bottom of the screen and not obvious!!

Ergonomy-wise, many things could be improved in the AskBot engine :wink:

Your sample file may be faulty: you have the section for “article two” included in the section for “article one”. I’m working on a changed architecture with the section made independent. This does not change the error but eliminates a possible difficulty with nested sections.

I’ll attach the file when finished with it.

I can help you to submit a but, I already have credentials on the bug site.

Apologies - over-enthusiastic cut-and-pasting!
v2 now attached with two separate sections