Special Character insertion

You changed the Special Character insertion protocol! I used to be able to type Alt+0151 and — would be inserted. Alt+0233 = é.
NOW all I get is some sidebar menu I will NEVER use!!!
Now, instead of one easy operation, I have to go through FOUR of them!

1 Like

This is a function of your operating system. Alt+0151and Alt+0233 insert — and é in any application.

The Writer-implemented way (not OS-way) of insertiong special Unicode keypoints is typing U+*<hexa_encoding>" (without quotes) followed by Alt+X.

For “é”, this is U+00E9 (hexadecimal instead of decimal) and for “—” (em-dash I assume), this is U+2014. In the latter case, index 151 is probably a legacy of old Windows XP/2000/… legacy 256-character code pages.

it’s long ago those break from ASCII to UNICODE. I remember quickly written letters outside the DOS-keys with external number-pad that’s obsolete.
Alt+0151 is no sign today.

Because position 151 is in C1 set U+0080-U+009F. OP didn’t mention his/her W$ version.

it’s enough making me weep with the signs and charakters. No possibitity to find any older UTF8-type C1 on my older mac-System. C0, C2, C3 … F4: yes. C2 is beginning by U+0080 with the €-sign.

Here is an another similar (solved) qoestion:

@JIM7 :
It is a regression bug which has already been flagged by many other users (duplicate bug list)

I had the very same problem as you. It was solved in this question [regression] cannot enter alt+number codes for unicode symbols anymore after updating to LibreOffice by deleting the default keyboard shortcuts for ALT+1, ALT+2, ALT+3, etc. … as a temporary workaround until the bug is fixed.

@JIM7 : sure that’s related to LibreOffice Writer ?

You respond by email and your signature dominates your actual (short) answer, when displayed on the ask site.
Please remove your signature, when you post here. …

1 Like