Specified device invalid error when attempting to connect to Google Drive

First off, the “Share” input box has NO mentions in the online help so I’m already missing a piece of this puzzle.

Secondly, I just get the error telling me that the specified device is invalid when I try to log in to google drive with the correct email and password.

After doing some digging online it seems to be a problem with having 2FA enabled on your account. I couldn’t find anyone posting a solution to this problem. If this problem is unsolvable, then PLEASE someone at least fix this error message to be helpful and not extremely crytpic. Very disappointing considering this feature has apparently been in LO since ~2016.

So, can someone get this explained to me? I’m willing to reinstall if this issue gets fixed or if I can get an explanation as to what I should do to get around this problem. (and also what the share box does/means)

What is the specific error message?

There are an extension (I never tried it) for connection to Google drive (I do not know if it works or not):


The two-factor authentication (2FA) requires every user to provide two pieces of information before being able to access a Google Account.

“The specified device is invalid.” This just means nothing to me.

I’ll reinstall LO and try it out, if this works better than the built-in function that’ll be kind of… silly

(com.sun.star.uno.RuntimeException) { { Message = "<class 'ImportError'>: cannot import name 'logMessage' from 'gdrive' (C:\\Users\\AZ\\AppData\\Roaming\\LibreOffice\\4\\user\\uno_packages\\cache\\uno_packages\\lu1312854bfb.tmp_\\gDriveOOo.oxt\\pythonpath\\gdrive\\__init__.py), traceback follows\X000a  File \"C:\\Program Files\\LibreOffice\\program\\pythonloader.py\", line 146, in writeRegistryInfo\X000a    mod = self.getModuleFromUrl( locationUrl )\X000a  File \"C:\\Program Files\\LibreOffice\\program\\pythonloader.py\", line 101, in getModuleFromUrl\X000a    exec(codeobject, mod.__dict__)\X000a  File \"C:\\Users\\AZ\\AppData\\Roaming\\LibreOffice\\4\\user\\uno_packages\\cache\\uno_packages\\lu1312854bfb.tmp_\\gDriveOOo.oxt\\ContentProviderProxy.py\", line 17, in <module>\X000a    from gdrive import logMessage\X000a\X000a", Context = (com.sun.star.uno.XInterface) @0 } }

Um, I don’t think that clicking the add button in the extension manager was correct…


This is probably solvable but there may be no one working on this problem. A few years ago it worked from time to time. Has not worked in a very long time.
As for requesting the message to be changed, this is the incorrect place for that. We are mostly users as yourself trying to help by using our knowledge of LO.
You can make the request yourself here > Bugzilla and since this is open source software, you can also volunteer to modify the source to incorporate the change.

My bad with that. I take it that there is no immediate temporary solution to this problem using stock LO, then.

Has anyone figured this out? I’d like to connect to google drive to access my files from my laptop as well as my desktop.

I cant figure out how to use the extension. I installed it but still get this error message “specified device invalid” when entering google drive as connect service

This is not a solution: please repost as a comment.