Toolbar text is white and not really visible

As you can see the color of the toolbar text is white/greyish and not really visible, only when hovered with the cursor you can see it a little bit. Everything else works fine though. Actually, I’m using the standard color theme of LO, icon set is Colibre, and LO Theme is Dark.

Any help is very appreciated. Thank you.

If you expect an answer, edit your question (answers are reserved for solutions) to add LO version and system name. Clarify " using the standard color theme" vs. “LO Theme is Dark”. You probably customised LO because default look does not use themes. Do you experience the same problem with another or default theme?

Guess I should not expect too much from LO community if LO breaks for no reason lol Anyways thanks

NoKbrd,

You can do your bit also (you are part of the community).

When this come to happen?

By the tooltip, all I can guess is that you are using a MAC on German language.

I am having the same problem, looks almost identical to the picture.

It seems to be happening in the “Tabbed” and the “Tabbed Compact” UI variants.
UI text is white on white, regardless of the theme settings under Options/LibreOffice/Personalization.

Tried changing the Application Colors under Options/LibreOffice/Application Colors, but there does not seem to be a setting for menu background, nor menu text.
I am running LibreOffice 7.1.2.2 64 bit on Windows 10 Pro 19041, LibreOffice is relatively freshly installed.

It’s not Windows related, as I have the same observation on a freshly installed LO on Arch Linux (7.2.5.2.0) with default configuration

I struggled with this for some time and discovered to fix this in Windows you have to stop using themes.
Tools > Options > Libreoffice > Personalisation
Select “Default look, do not use Themes”
Close and then reopen LibreOffice and the text colour should be fixed.

Icons you can change (Galaxy looks good), but with any theme applied the toolbar text goes to white without the toolbar background changing from white. This is with the tabbed style toolbar: I didn’t try any others.

1 Like

Thank you for the tip! Solved my issue right away!

I tried every option for this problem but another one worked fine for me.

From Settings->LibreOffice->View->Icon Style

Change it from Automatic to one of the dark themes if you are also using a dark theme for your desktop environment and click apply to observe the change. This changes the foreground color of the MenuItem elements to white so they become visible.

Changing the “Personalisation” to “Default look, do not use Themes” and trying to change the Icon Style both did not fix it on my end.

My device: Windows 11 with every setting set to default.

What solved the problem for me was, either changing the language of the interface from German to English, or, while the interface was still in German, changing the user interface from “Tabbed” to “Standard Toolbar”.

So I’m guessing it has something to do with the localization, in some cases???

Screenshot 2022-12-12 111609

I’m just leaving this here, in case anyone else is looking for an answer.

Sounds like a bug if that fixes it. Can you report a bug? See How to Report Bugs in LibreOffice - The Document Foundation Wiki

There is a similar thread on the German forum
Bug in Theme “Dark” und Benutzeroberfläche “In Registern”???

It points out tdf#121877 as a possible candidate.

1 Like