Why do I get these strange symbols when uploading a file.

EDITED as I have concluded this is now more a Chromebook than a LO issue. I did manage to copy and paste as rtf but with a fresh download of LO it remained. I will add back if I find and learn anything on a Chromebook form that is relevant here.

Edited to say I have now attached two attachments made in LibreOffice and showing what happens. It gives a partial answer as I discovered pasting as RTF works.

It still begs the question of why all the other ways you can copy and paste have the strange symbols.

“You’ve achieved”

If I create a new ODT file and try to paste into that the same thing happens. In addition, if I simply copy and paste I get the problem and every sentence is numbered. When I try to paste special, then I lose the numbers and get the symbols.

This happens when I upload a file. Please, can someone tell me why and what to do?
It also happens when I try to copy and paste into a downloaded template to another.

Thank you.

I am using a Chromebook.
I uploaded to Prowritingaid.com (Cannot use the editor in libreoffice so have to use the web version.)
Due to Chromebook limitations I can only get libreoffice 5.2

In answer to comments about ISO’s below:

The problem happens even copying from one Libreoffice file to another. The document where I first found the problem is a libreoffice ODT file. I uploaded using the Chrome browser. The document was formatted, but the problem is in the body text, not the headers. I understand what you say about the apostrophe but why would it happen in libreoffice files when I am not uploading to anywhere, but copying and pasting?

If the problem happens in ODT files, then is there something that I can do to change things in my version of libreoffice. Reinstalling has not solved the problem. Chromebooks can only get to Libroffice 5.2.

(I do not know how to put a BOM mark before a document. I am lost there. For people like me, we need not just the information you give, but also the information as to how you would actually do it from the point of opening the file! I will ask another question about that!)

New origninal file1.odt
New origninal file2.odt

(edit: fixed download-file links)

This seems unrelated to LibreOffice. Perhaps you could ask the website to which you are uploading.

I second robleyd’s comment. The issue seems to be irrelevant here, especially considering that you specify that

Cannot use the editor in libreoffice

Anyway, what kind of file are you trying to process?

Please see my comment above. It IS relevant as I find the same thing happens when I copy and paste into a new libreoffice file. In fact I edited to say where I had first encountered the probllem in answer to the person who kindly did give me information.

Strange it happens in a LO-to-LO process. Can you attach a sample file if not confidential? Or at least an excerpt of it with the mishap.

I suppose that OP ( @JackyAnn ) needs to re-write the question from scratch. I tried to read the question several times, and couldn’t understand what happens when.

A good question would look similar to this:
[OS version; LO version]

I open pre-existing ODT file (link here) (or create a new text document); write there these characters: “ABC” (using that keyboard layout); save it back; then close LO, and try to upload the file to resource XYZ using browser NNN. Then I open the file in web view, and see this: … (screenshot). Or I select characters from here to there, press Ctrl+C to copy to clipboard, switch to another newly created text document, and Ctrl+V, and see this …

The level of details you give determines if others, not standing behind you, will be able to understand your problem in the first place - the neccessary step to be able to come with a useful advise.

This essay is a must-read to ask good questions.

The downvote here looks unfair - I upvote to compensate. If someone downvotes: please provide some explanation in cases there’s nothing obvious.

If the problem happens in ODT files

Exactly, if. I can see no proof to it. The problem may be about the server, we don’t know how files are processed. In such a case, you can’t do much.

By the way, I tried to upload a sample ODT file produced with LO Writer containing a single phrase:

You’re right.

It has been processed correctly.

I’ve created and uploaded another one with the same content using LO Still processed correctly.

Can you share the file?

I have reinstalled LibeOffice. I have made a new file with different text and tried to copy and paste every way there is not uploading to anywhere and the problem remains. It happens wherever I copy or paste of upload but NOT if I copy from elsewhere and paste. There is no pont telling a chrome user anything to to with LO 6 and beyond. We cannot get it. We are limited to L0 5. It cannot be the server as the problem happens working in LO offline. I do not want to share a long file but will make and upload a short one. My current theory is this is related to LO on a Chromebook but I am away and cannot use other hardware to experiment.

the problem happens working in LO offline

Really? As I understand, the problem happens when you upload a file to the server.

@gabix: “and tried to copy and paste every way there is not uploading to anywhere and the problem remains”

I am beginning to think this is a Chromebook issue…

You file already contains garbled text such as




So, it’s not a conversion or encoding issue. No wonder, that you see the problem wherever you copy and paste the text. How did you produce it? Yes, it might be a Chromebook issue (I have no experience with such an environment). Or not.

I suppose that it’s something about how LibreOffice treats clipboard data encoded as UTF-8. The other day I remember seeing another developer mentioning problems there, saying that we only correctly handle UTF-16-encoded clipboard data (on some apple OS? - don’t remember correctly) - that might be a similar case…

Worth a bug report. Possibly with a screencast (video showing the problem; also would be great to see which different clipboard formats are offered in LO when pasting).

I doubt, it is a reason for a report, at least, at Bugzilla. Chrome OS is not an officially supported operating system, thus, the issue can hardly be qualified as a bug.

@mikekaganski: by default, stored plain text files are UTF-8 unless there’s a sequence 0xFE 0xFF or 0xFF 0xFE at the beginning to establish UTF-16 and its endianness. Consequently, if UTF-16 is internal format, LO must convert input files at some time. After that, all internal data is UTF-16. Problem may occur when external data is passed from some app to LO via the clipboard. I don’t know how encoding is advertised in the clipboard, if any. Deciding between UTF-16 and UTF-8 is not obvious, moreover on short sequences.

Again a very fascinating thread. The text from the example file can be reversed to readable text. Using Notepad++ with an empty new file (UTF-8) and copy / paste a paragraph from the example file it worked with ‘convert to ANSI’ and afterwards changing encoding back to UTF-8. Maybe this helps to light up this mystery.

From @JackyAnn I’d appreciate to read a clarification on what ‘upload an .odt file’ means exactly. Is it about an explicit file upload of the local odt-file to prowritingaid.com or is it copy & paste the hole content from an .odt file into that website which generates an OO .odt file with this?

Heh, “fascinating thread”…

One person gets the idea that the question is about uploading. Another talks about plain-text files. Yet another advises how to reverse to readable text the utf-8-read-as-ISO-8859-1 garbage in an ODT file (!).

I need to repeat what I wrote above: poor description confuses people, and so - it’s the uttermost priority for asker to try their best and describe as clear and as step-by-step as possible.

If the bug report should be filed against TDF or against ChromeOS is questionable; despite many OSes are not officially supported, we do take their patches, like for Haiku. So - it’s better to have a report here than not to have anywhere.

Clipboard management is strictly OS-dependent; and if I understand the question correctly, and typing “I’m OK”, copying it, and pasting back to the same LO breaks the apostrophe, it’s clearly LO-to-OS-clipboard problem… please file it.

I an lost. Do LO users not save a file as ODT? I do. Why would that confuse anyone?

A side comment: GalliumOS is a Xubuntu-based Linux distro for Chromebooks. Looks interesting and might be worth trying.