Writer auto complete not working

I’m using a Windows 11 tablet with keyboard and the auto complete feature just simply does not work. I have gone into tools, auto correct, auto correct options, word completion made sure enable word completion was checked, I have played around with word length, unchecked everything restart recheck everything, tried both show as tip and not. I have googled this out and back but I almost exclusively find “how to turn this off” articles.
I usually can figure things like this out but on this one I’m just flat out stuck.

If you start a new session with a blank document there are no words in the Word Completion list. As you type or add words it will collect those ones complying with the rules you set.

If you have a list of words you want to autocomplete then open that document and make sure When closing a document, remove the words collected from it from the list is not ticked. Those words are then available for other documents in the same session. Make sure you have Collect words ticked if you want to add words.

The below word completion list was empty until I added some Dummy Text (dt+F3). It seems that the language is not taken into consideration as you see that English (NZ) is in the AutoCorrect Options box but the document is English (UK)

Does any of the above work?

No, I check all those screens. It has collected words just fine, even several non standard words I’m using for various projects. The problem is that it will not function when making entries in the document, even when the word is in the list, there is no option to “complete” a word in the document.

To complete a word, press Enter key. Consider ticking the box to add a trailing space so you can start typing the next word.
To cycle through collected words with the same starting letters, press Ctrl+Tab (or Ctrl+Shift+Tab to go in reverse)

See Help (Word Completion for Text Documents)

No, there is no option to press enter.

When you see the tooltip with the suggested word and you press the Enter key nothing happens?


Does it work in Safe Mode? Click Help > Restart in Safe Mode > Continue in Safe Mode and try there.

Have you disabled Tooltips in Expert Configuration?

I do not see any tool tip. I have not done anything in expert configuration, safe mode did not help.

What version of LibreOffice are you using? Click Help - About LibreOffice and click the button on the dialogue to copy the information to the clipboard.

Maybe it is an issue with tooltips. Untick Show as tip and see if it works by pressing Space to confirm suggestion.


Note: Pressing Enter can give unexpected results in
Bug150455 tdf#150331

[Edit] There are two suggestions you could try on this old Ubuntu question libreoffice - libre office word completion not working - Ask Ubuntu

Version: (x64) / LibreOffice Community
Build ID: 728fec16bd5f605073805c3c9e7c4212a0120dc5
CPU threads: 4; OS: Windows 10.0 Build 22000; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Tried unchecking show as tip, did not help. I tried both suggestions in the above thread and they did not fix the issue.

There are two on-screen keyboards in Windows 11, only one works properly like a keyboard. Click start menu and search for On-Screen Keyboard. Use that instead not Touch Keyboard. As a bonus, you will get the keyboard’s own suggestions as well along the top of the keyboard.

1 Like

I’m using an external keyboard not an on screen keyboard.

What keyboard brand and model number? Does the driver have software that offers its own predictive text. That could over-ride or inhibit LibreOffice’s own predictive text the way that the Touch Keyboard does.

This is the keyboard information standard Microsoft drivers

what does it say on the underside of the keyboard?

nothing, no text. It’s a keyboard that came with the unit

OK I am giving up now, I can’t see what you have in front of you or what software came with the “unit”. You could try with a different keyboard.
Did you try using the On-Screen Keyboard?

Tablet mode in Windows 11 has no documentation. I assume the Touch Keyboard is enabled by default in Tablet mode. If you switch on the On-Screen Keyboard (by Settings > Accessibility > Keyboard > On Screen Keyboard or WinKey+Ctrl+O) it might disable the Touch keyboard. If it does and LO predictive text works then you can fade the keyboard by clicking Fade and then use your physical keyboard. You can also set it to open on boot in the Options key.
If that doesn’t work connecting a USB keyboard might disable the Touch Keyboard.
If all else fails, turn on predictive text for the Touch keyboard and hope for the best but it won’t be LO predictive.

I tried hooking up a Logitech K350 to see if that corrected the problem, but it did not. I made sure the touch keyboard was disabled and tried using the onscreen keyboard but that also did not help.

You could try Control Panel > Programs and features > LibreOffice right-click and select Repair

Otherwise run through the list here before submitting a bug report, First steps to take before submitting a bug - The Document Foundation Wiki

Outside chance that it might be a graphics issue in displaying tooltips. Can you see tooltips when you hover over the icons on the toolbar? If not, try disabling Skia: click Tools > Options > LibreOffice > View and untick the box Use Skia for all rendering

To revisit this earlier comment, see How to disable or delay tooltips to toggle display of tooltips in content. NOTE Careless use of Expert configuration can damage your installation.

I think this is related to my problem. In my case, the yellow “Help Tip” does not appear in Autotext. Using Libre

When I tried it with autocomplete, your problem was replicated. The yellow “Tool Tip” does not appear, so you cannot press the Enter. Just like in my case.

I tried experimenting with Libre Portable. I observed this, about your problem:

6.4.7 working
7.0.6 working
7.1.8 working
7.2.7 not working
7.3.5 not working

just like also in my case.

Please try if your problem is gone in 6.4.7, 7.0.6 and 7.1.8. If it is, then this is a bug. I already reported mine as EarnestAl suggested.