Writer - Issue with screenshots getting dragged down / attached to cursor when hitting enter; hence can't insert additional screenshots below

I have an ‘issue’ with Writer which has been bugging me for a while:

Often when I paste training course screenshots in a Writer document (with no text between the screenshots), after the first 2 or 3 screenshots, when I hit ENTER to TRY to insert a blank line so I can paste the next screenshot, the cursor instead attaches to the prior screenshot and drags the screenshot with it (it it anchors the screenshot to the cursor so no blank line is inserted); this results in not being able to paste the next screenshot below the last one (if I still try to paste, the new screenshot obviously simply gets pasted OVER the prior screenshot which is not the goal).

I tried the Anchor setting (changed it to ‘Anchor to Paragraph’ e.g.) and it worked (allowed me to insert a blank line and insert the next screenshot); but it only worked for that ONE screenshot (not sure why the default Anchor setting results in issues).
The next screenshot had the same exact issue again. I then decided to try a ‘CTRL A’ - i.e. ‘select all’ (i.e. entire document) and then selected ‘Anchor to Paragraph’ with CTRL-A selection still active.
That seems to have worked. (Need to experiment more)

Is there any way / any other setting to prevent screenshots from dragging down when I try to hit ENTER to insert a blank line after a screenshot, without having to change the Anchor setting on each new document?

I have a bunch of training courses to take and I create a separate Writer doc for each course (each doc contains all the screenshots from that particular course).

I tried MS WordPad and it doesn’t have the above screenshot anchoring/dragging issue.

First thing first: mention OS name, LO version and save format. If .doc(x), expect compatibility issues.

What is the anchor mode of your pictures?

Do you know how to use frame styles? A double-click (one per image, alas) would confer all the pictures the same characteristics and solve the position issue.

Have you several images per paragraph?

OS Win 10 64-bit
Format: .docx

Quick update:

I noticed this issue / behavior is because every time I paste an additional screenshot, that screenshot defaults back to ‘Anchor to Character’…

2 solutions / workarounds:

Option 1) major pain (given I am sometimes doing 100 screenshots per doc. so this step would be required 100 times) - Click on the prior screenshot and change the achor settings from ‘Anchor to Character’ to ‘Anchor to Paragraph’…

Option 2) much easier, type any character after each screenshot (e.g. one letter); this removes the anchor and allows me to paste the next screenshot.

PS: I added this comment and my reply crossed yours (i…e I posted this update before seeing your question, which was posted while I was typing and sending my update.
Anchor mode is answered as part of my comment. :slight_smile:

Adding a character does not remove the anchor, it only allows to anchor to a separate character instead of the same.

Since your document is saved .docx, no solution I could suggest will be persistent across save/reopen because Word has no notion of styles beyond paragraph styles. Have you a professional constraint (company rule, team work with Word aficionados, …) preventing you from saving .odt?

Be aware that Writer is not a drop-in replacement for Word. It is another document processor based on different principles. Implemented features are different. If you want to benefit from them, you must save .odt.