Ask Your Question
3

How to save cursor position in Writer? [closed]

asked 2012-03-13 11:08:10 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

When using OpenOffice, the cursor position at the time of saving was remembered, so that when the document was re-opened, you could resume editing or whatever from that position. LibreOffice Writer re-opens at the beginning of the document. I've looked in customise and options with no luck. Does anyone know how to enable cursor position save?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-29 23:26:27.908421

Comments

I've tried all of these solutions and none work for me. Any other ideas?

gracelikerain gravatar imagegracelikerain ( 2014-07-20 03:59:12 +0200 )edit

Which LO version are you using? Cursor position is not saved in documents created with LO 4.3...(another regression...) In all previous versions it works as expected IF the name of the user is the EXACTLY the same.

Pedro gravatar imagePedro ( 2014-07-20 11:29:23 +0200 )edit

I just realized why it wasn't working. It works great for all my documents saved as *.odt files. The largest file I'm working on is a *.doc file. When I re-saved it under the *.odt format, it opened like a champ! Thanks for all your help!

gracelikerain gravatar imagegracelikerain ( 2014-07-20 23:21:31 +0200 )edit

@gracelikerain, I'm glad you figured the solution and that my answer helped. That is an important detail missing in my answer (although it is correctly mentioned in the comment by @froz). I'm adding it to my answer.

Pedro gravatar imagePedro ( 2014-07-21 00:03:45 +0200 )edit
manj_k gravatar imagemanj_k ( 2014-07-31 19:25:35 +0200 )edit

Your point's important, Pedro. It doesn't work in the latest version of LO. I foolishly upgraded to 4.3.1.2 and lost it. Grrr!

GeoffP gravatar imageGeoffP ( 2014-09-25 10:40:09 +0200 )edit

Currently, the cursor position is not saved in my odt documents. I have filled in the user data (had done that already) and the files were created before the last update -- one file is even more than a year old. Currently on version 4.2.8.2.

Frank Lekens gravatar imageFrank Lekens ( 2015-01-23 17:13:30 +0200 )edit

4 Answers

Sort by » oldest newest most voted
9

answered 2012-03-13 11:57:53 +0200

Pedro gravatar image

updated 2014-07-21 00:11:11 +0200

The cursor position is saved (only in Open Document Files i.e. files ending with .ODT) if you fill in the personal information(first and last name are enough). Go to Tools, Options, User Data.

When the user is identified, LibreOffice will open the document where the user left off. This makes sense because a different user opening the same document will probably want to start from the beginning. If there is no user identification LibreOffice assumes it is a new user and always opens from the beginning.

edit flag offensive delete link more

Comments

It looks this is only working for ODF (it fails for DOC for example) and also there is probably some bug in v4.0.1 - it opens in correct line, but exactly 6 characters to the left of position saved. I have reported bug: https://bugs.freedesktop.org/show_bug.cgi?id=62398

froz gravatar imagefroz ( 2013-03-16 07:37:28 +0200 )edit
0

answered 2012-07-24 04:31:54 +0200

I got mine to start returning to the last cursor position. I did enter personal information. I don't remember if that fixed it. The other thing I did was to goto TOOLS/OPTIONS/LOAD SAVE/GENERAL, then under ODF Format Version, I set it back to 1.2 instead of 1.2 extended. That is when it started working again. I am a writer and the LAST EDIT is very important, if not the most important feature to me.

edit flag offensive delete link more
0

answered 2013-01-12 06:38:45 +0200

None of the above worked for me. However, File - Properties - General - check "Apply user data" and OK, then it saves cursor position.

BTW, why can't this suite have a simple "Quickmark" feature like WordPerfect?

edit flag offensive delete link more

Comments

Because no one added it yet :) You can make a Feature Request at Bugzilla (https://bugs.freedesktop.org/)

Pedro gravatar imagePedro ( 2013-01-12 11:26:48 +0200 )edit

See also → this answer by @cloph: (Shift+F5).

manj_k gravatar imagemanj_k ( 2013-01-12 17:24:05 +0200 )edit

Just check the Apply User Data to File-Properties screen, changing the document, remember the position and save the document. Close the document and open it again. I tried several times and always open the document in the correct position when it has been marked "Apply user data".

B.Horvat gravatar imageB.Horvat ( 2013-01-22 19:14:09 +0200 )edit
0

answered 2013-03-15 04:05:33 +0200

None of these solutions work for me. I have set "First/Last name/Initials" in Options → LibreOffice → User Data. I set the "ODF format version" to "1.2" in Options → Load/Save → General. I have checked "Apply user data" in File → Properties → General.

Still, each time I open the file, it starts with the cursor at the top, regardless of where the cursor was when I saved the file. Any ideas?

edit flag offensive delete link more

Comments

1

Try Shift+F5.

That should work for all documents (even if created/saved by another "user").

manj_k gravatar imagemanj_k ( 2013-03-16 10:34:15 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-03-13 11:08:10 +0200

Seen: 7,082 times

Last updated: Jul 21 '14