How to save cursor position in Writer?

When using OpenOffice, the cursor position at the time of saving was remembered, so that when the document was re-opened, you could resume editing or whatever from that position. LibreOffice Writer re-opens at the beginning of the document. I’ve looked in customise and options with no luck. Does anyone know how to enable cursor position save?

I’ve tried all of these solutions and none work for me. Any other ideas?

Which LO version are you using? Cursor position is not saved in documents created with LO 4.3…(another regression…) In all previous versions it works as expected IF the name of the user is the EXACTLY the same.

I just realized why it wasn’t working. It works great for all my documents saved as *.odt files. The largest file I’m working on is a *.doc file. When I re-saved it under the *.odt format, it opened like a champ! Thanks for all your help!

@gracelikerain, I’m glad you figured the solution and that my answer helped. That is an important detail missing in my answer (although it is correctly mentioned in the comment by @froz). I’m adding it to my answer.

OP: @hbgjerome

Your point’s important, Pedro. It doesn’t work in the latest version of LO. I foolishly upgraded to 4.3.1.2 and lost it. Grrr!

Currently, the cursor position is not saved in my odt documents. I have filled in the user data (had done that already) and the files were created before the last update – one file is even more than a year old.
Currently on version 4.2.8.2.

The cursor position is saved (only in Open Document Files i.e. files ending with .ODT) if you fill in the personal information(first and last name are enough). Go to Tools, Options, User Data.

When the user is identified, LibreOffice will open the document where the user left off. This makes sense because a different user opening the same document will probably want to start from the beginning. If there is no user identification LibreOffice assumes it is a new user and always opens from the beginning.

It looks this is only working for ODF (it fails for DOC for example) and also there is probably some bug in v4.0.1 - it opens in correct line, but exactly 6 characters to the left of position saved. I have reported bug: https://bugs.freedesktop.org/show_bug.cgi?id=62398

You must also have made a change during the previous edit.

I got mine to start returning to the last cursor position. I did enter personal information. I don’t remember if that fixed it. The other thing I did was to goto TOOLS/OPTIONS/LOAD SAVE/GENERAL, then under ODF Format Version, I set it back to 1.2 instead of 1.2 extended. That is when it started working again. I am a writer and the LAST EDIT is very important, if not the most important feature to me.

I was having same problem with ODT file after moving everything to new PC (Windows 10) - had worked fine on older PC (Windows 7). Tried all methods mentioned then used this option under Tools/Options/Load and changed ODF settings to just Version 1.2. Same problem so went to File>Properties>General, unchecked option for Apply User Data, saved and exited LibreOffice. Then reopened LibreOffice and checked this option once again. Now it works! Should not have to jump through all these hoops for a simple option.

None of the above worked for me. However, File - Properties - General - check “Apply user data” and OK, then it saves cursor position.

BTW, why can’t this suite have a simple “Quickmark” feature like WordPerfect?

Because no one added it yet :slight_smile: You can make a Feature Request at Bugzilla (https://bugs.freedesktop.org/)

See also → this answer by @cloph: (Shift+F5).

Just check the Apply User Data to File-Properties screen, changing the document, remember the position and save the document. Close the document and open it again. I tried several times and always open the document in the correct position when it has been marked “Apply user data”.

None of these solutions work for me. I have set “First/Last name/Initials” in Options → LibreOffice → User Data. I set the “ODF format version” to “1.2” in Options → Load/Save → General. I have checked “Apply user data” in File → Properties → General.

Still, each time I open the file, it starts with the cursor at the top, regardless of where the cursor was when I saved the file. Any ideas?

Try Shift+F5.

That should work for all documents (even if created/saved by another “user”).