Ask Your Question
0

Weird Gray Spaces Between Words

asked 2019-06-27 22:52:44 +0200

kristiambrose gravatar image

Hi guys!

More often than not I do not type right in Libre Writer, I usually write someplace else, usually one of two places and transfer it over. Actually, that's probably a really bad habit lol. Anyway, I usually write in either Notepad or in Google Docs (and sometimes grammarly). Usually everything transfers perfectly. But, last night I was having a weird issue transferring from Notepad OR Google Docs where 99% of the time it's creating this really odd "space" that is gray after every comma, colon, explanation mark, etc. And 1% of the time between regular words with no punctuation. I am wondering if anyone else has had this issue and how I get rid of it without having to go through and fix it one by one.

I am attaching an example so you can see what I mean. At first I thought it might be a formatting issue so I selected the text and did the "remove formatting" option, all that did was remove my custom font and it kept the gray space lol.

image description

I have never ever ever had this happen so if someone knows a quick fix, I would greatly appreciate it. Thanks ahead of time.

I also have the earliest version of Writer and I am on Windows 10.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2019-06-27 23:26:22 +0200

RGB-es gravatar image

Most probably it's a "non-breaking space" (U+00a0). In Writer you introduce it by pressing Ctrl Shift Space but for some reason it's quite common on many web pages/applications, so when you copy/paste text it appears in your document. Just delete them.

Unless you actively use some of the "non standard spaces" (n-space, m-space, word joiners, etc.) on purpose, it's quite easy to convert all those spaces in "normal spaces" by using regular expressions: open the S&R tool (Ctrl H), check "regular expression" box under "more options," write [:space:] in the search box (this expression search for all the different kinds of spaces), a normal space in the replace box and press "replace all."

edit flag offensive delete link more

Comments

Just a note: [:space:] (alternative POSIX-like syntax for \p{space}) matches tabs, among other things. If needed, tabs may be excluded from the match using this regex: [\p{space}--\t] (or [[:space:]--\t]). See regex help page of the engine used in LibreOffice for more details.

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-11 06:27:20 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-27 22:52:44 +0200

Seen: 40 times

Last updated: Jun 27