Ask Your Question
0

Can not access libre office docs

asked 2020-09-24 15:12:29 +0100

John Healy gravatar image

Hello. Since an update on my computer, I can not gain access to my previously saved libre office docs. When i click or right click on the folder, it brings me back to the desk top. I know that if I right click I can change the dafault setting to libre office but the problem is that it will not allow me to right click, it just throws me out.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2020-09-25 05:19:25 +0100

Earnest Al gravatar image

updated 2020-09-25 05:20:37 +0100

It is probably an anti-ransomware setting somewhere to make you feel safer and calmer

Mac

You probably need to give LibreOffice full disk access from System Preferences > Security & Privacy. See this site on how to do it if you aren't sure: https://macpaw.com/how-to/full-disk-a... .

Windows

If you don't have a third party anti-virus have a look at this: Defender Controlled Folder Access

Turn Off Defender

  • Select Start  > Settings  > Update & Security  > Windows Security > Virus & threat protection.
  • Under Virus & threat protection settings, select Manage settings.
  • Under Controlled folder access, select Manage Controlled folder access.
  • Switch the Controlled folder access setting from On to Off.

If you do have a third party anti-virus go into settings and then look for something like anti-ransomware or folder protection. Have a look at the blocked apps list, if you see soffice.bin in there change it to Allowed (you might have to read AV help if not obvious). Otherwise go to the Allowed Apps setting and allow soffice.bin, this might not be easy so you might have to add the different LibreOffice executables (Calc, Writer, etc.) to the Allowed list. Note that 3rd party anti-virus might make files Read Only so you can create a new file but you can't save it subsequently. Sometimes, you might need to reboot after allowing a program access.

Cheers, Al

edit flag offensive delete link more

Comments

Thank you, Al. Taking away folder access from Defender worked, it looks like. I had another glitch which I think I created earlier, messing around with problem, and I get a couple of windows saying I can't load BASIC. I click through them and everything looks good. But I'll worry about that later, if at all. Thanks again.

MEFraser gravatar imageMEFraser ( 2020-10-18 23:31:37 +0100 )edit
0

answered 2020-09-24 20:48:25 +0100

erAck gravatar image

Let me guess: you are using Windows; you didn't tell (you should had).

Let me further guess, it was a Windows update that destroyed the file name extension / type association with an application, because Windows thinks it knows better and wants you to use MS-Office.

Let me then guess that to be able to click to open you want to re-establish those associations; there are some (or plenty?) hints about that in this Ask place because Windows really likes to play this trick on its users.

The simplest probably is to invoke the LibreOffice installer and let it repair the installation and re-establish file type associations. There are other means to do that in Windows settings or on the command line, but I don't have details at hand.

Meanwhile, to be able to just open a document you can of course also invoke LibreOffice and open a document from within the application with File -> Open and navigating to its location.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-24 15:12:29 +0100

Seen: 90 times

Last updated: Sep 25