We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

Can't install Dutch language pack on MacOS [closed]

asked 2021-02-06 14:13:14 +0200

-rob- gravatar image

updated 2021-05-18 00:01:08 +0200

Alex Kemp gravatar image

Environment:

Version: 7.1.0.3 / LibreOffice Community Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c CPU threads: 4; OS: Mac OS X 10.16 Big Sur; UI render: default; VCL: osx Locale: nl-NL (nl_NL.UTF-8); UI: en-US Calc: threaded

Problem:

When trying to install the Dutch language pack I get the message: /Applications/LibreOffice.app/Dit is geen geldige installatie van LibreOffice 7.1. (not a valid installation of LO 7.1) Run the installer again and choose a valid LibreOffice 7.1 installation

I removed LO completely and re-installed LO 7.1.0.3. Installation of the language pack still throws the same errror!

I never had this before (I always follow the LO latest community edition). My environment was updates to MacOS Big Sur between LO 7.1.0.2 and LO 7.1.0.3. Could that have something to do with it? Anyone knows whats going on?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2021-05-18 00:01:26.926248

4 Answers

Sort by » oldest newest most voted
0

answered 2021-02-06 16:31:34 +0200

Opaque gravatar image

updated 2021-02-06 16:43:33 +0200

Hello,

this is bug tdf#134607 - LO7RC1 - LANGPACK macOS - many versions fail to recognize LibreOffice 7.0 / 7.1 installation as valid on Catalina and Big Sur

Workaround:

  • Open Finder
  • Go to Finder -> Preferences -> Advanced
  • Disable option [ ] Show all filename extensions
  • Install the langpack
  • Optional: Restore option setting [x] Show all filename extensions

image description

Tested using LibreOffice

Version: 7.1.0.3 / LibreOffice Community, Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 4; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US, Calc: threaded

Hope that helps

edit flag offensive delete link more

Comments

Super, this works. Thanks a lot.

-rob- gravatar image-rob- ( 2021-02-06 21:03:11 +0200 )edit

If the answer works for you, please consider to click the check mark (✔) next to the answer. This is the ways to indicate that there is a correct answer. There is no need to close an answer. Thanks in advance...

Opaque gravatar imageOpaque ( 2021-02-06 22:19:09 +0200 )edit

Worked for me. LibreOffice 7.1.0.3 and two language packs (Swedish and English UK). Turn off 'show all filename extensions', install language packs successfully, re-enable 'show all filename extensions'.

Stu-ey gravatar imageStu-ey ( 2021-02-08 18:49:48 +0200 )edit

Thanks a lot. It worked perfectly. Installed the first time, in fact without requesting the second step of locating LibreOffice, as soon as I open the installer, copy the files directly ... I have even reopened the installer because the installed box is hidden and I thought I had not done nothing. But no, all good, it had been installed and I have already opened LO and checked that it is translated. Very good. Thanks again.

MacTerrassa gravatar imageMacTerrassa ( 2021-02-27 15:13:33 +0200 )edit

Unfortunately, that didn't work for me, even after reboot of the computer. MacOs Mojave 10.14.6. German translation I tried Libre Office 7.0.5 and 7.1.1.

bbbbb gravatar imagebbbbb ( 2021-03-25 10:16:23 +0200 )edit

That didn't work for me, in macOS 10.12.6 Sierra.

charlie.it gravatar imagecharlie.it ( 2021-03-25 17:24:09 +0200 )edit

@bbbbb and @charlie.it : Could you elaborate on what exactly fails... As @prof290546 notes: If in the second step "this is not a valid LO version" is shown. You can just click through, en subsequently select the LibreOffice.app in the application directory that shows.

-rob- gravatar image-rob- ( 2021-03-28 15:10:14 +0200 )edit

Because I reach the maximum comment lenght, I divide the answer in two separate comments. The steps I did with LibreOffice (v7.1.1.2):

1. Make sure "Finder -> Preferences -> Advanced > Show all filename extensions" is unchecked. 2. Double-click "LibreOffice_7.1.1_MacOS_x86-64_langpack_de.dmg" to open the image. 3. Double-click "LibreOffice Language Pack" to open the installer. 4. Gatekeeper window opens in german: "LibreOffice Langguage Pack" is an app downloaded from the internet. Are you sure you want to open it?" 5. I click "Open". 6. The german welcome interface appears: "Willkommen beim LibreOffice 7.1 Language Pack Installations-Assistenten Mit dieser Installation werden bereits installierte Versionen von LibreOffice aktualisiert Das könnte einen Moment dauern." 7. I click "install*"

bbbbb gravatar imagebbbbb ( 2021-03-28 17:24:53 +0200 )edit

8. Installer window opens: "Wählen sie die LibreOffice 7.1 Installation, für welche Sie LibreOffice Pack installieren möchten" (Select the LibreOffice 7.1 installation for which you want to install LibreOffice Pack) 9. I press: "Nicht aufgelistet (wählen Sie den Ort in einem weiteren Schritt)" Not listed (choose the location in a further step) 10. I choose LibreOffice from the Application folder 11. Error message appears: "/Applications/LibreOffice.app/Dies ist keine gültige Installation von LibreOffice 7.1. Starten Sie das Installationsprogramm erneut und wählen Sie eine gültige Installation von LibreOffice 7.1" (restart the installation application. this is not a valid LO version)

bbbbb gravatar imagebbbbb ( 2021-03-28 17:25:49 +0200 )edit

I followed all the instructions but in macOS 10.12.6 Sierra, it doesn't work

charlie.it gravatar imagecharlie.it ( 2021-04-02 17:59:32 +0200 )edit
0

answered 2021-03-06 12:29:29 +0200

I have Big Sur 1.2.2. Does not work!

edit flag offensive delete link more

Comments

2

Totally useless post (not telling what does not work exactly and in what manner), additionally posted as a solution (as if @prof290546 couldn't read the "Propose Your Solution" in the box where they wrote)...

Mike Kaganski gravatar imageMike Kaganski ( 2021-03-06 12:34:51 +0200 )edit

Mike, in stead of being so harsh, you could also ask what exactly is not working...

-rob- gravatar image-rob- ( 2021-03-06 12:55:17 +0200 )edit

Dear Mike, what a harsh comment for me as a new user. The topic of this post is, that the installation of the German Language Pack is not working. There is written a solution. And this solution is not workiing on my MAC Mini.

prof290546 gravatar imageprof290546 ( 2021-03-06 12:58:03 +0200 )edit
2

@prof290546: ok, you are new (but personally for me, when I'm new somewhere, I usually spend some time reading "how to use this site", and at least I would be warned reading the other off-topic "answer" right here, that one starting with "Worked for me too", with a reply "Please do not use Add Answer if you actually don't answer a question").

But anyway, you did not tell what LibreOffice version you were trying to install; what language pack was being installed; what specifically you did (we don't know if you followed the suggestion to the letter), and what did you see (was the error you finally saw the same or a different).

By the way:

The topic of this post is, that the installation of the German Language Pack is not working

Wrong. The topic was "Can't install Dutch language pack" (not that it matters though).

Mike Kaganski gravatar imageMike Kaganski ( 2021-03-06 14:02:49 +0200 )edit

Dear Mike, this is the first Blog, where I was received in a such unfriendly matter: i will leave now. By by.

prof290546 gravatar imageprof290546 ( 2021-03-06 14:32:56 +0200 )edit

prof290546: Hi, In the original text is also the message: "this is not a valid LO version". You can just click through, en subsequently select the LibreOffice.app manually. That worked for me.

I am now on: Version: 7.1.1.2 / LibreOffice Community Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676 CPU threads: 4; OS: Mac OS X 11.2.2 (Big Sur); UI render: default; VCL: osx Locale: nl-NL (nl_NL.UTF-8); UI: en-US

With this combination I didn't see the problem anymore.

-rob- gravatar image-rob- ( 2021-03-06 15:56:16 +0200 )edit

i will leave now.

Oh, minus one moron here. Wonderful news.

gabix gravatar imagegabix ( 2021-03-07 16:19:32 +0200 )edit

@gabix & @Mike Kaganski: Can not vote a comment down, pitty...

-rob- gravatar image-rob- ( 2021-03-07 16:48:05 +0200 )edit
0

answered 2021-02-08 21:53:02 +0200

rajosj gravatar image

Worked for me too. Latest Catalina, MBP 16, hungarian language. Thanks.

edit flag offensive delete link more

Comments

1


Please do not use Add Answer if you actually don't answer a question but commenting an answer or responding to another user’s comment. Please use add a comment for that purpose. Thanks in advance …

Opaque gravatar imageOpaque ( 2021-02-08 22:44:38 +0200 )edit
0

answered 2021-03-30 11:02:36 +0200

sbgraphic gravatar image

Hello,

Thanks for this workaround but in my case I had to tick that box in order to make it work ! (Enabling show all filename extentions) in order to install "LibreOffice_7.1.1_MacOS_x86-64_langpack_fr"

Using LibreOffice 7.1.1 Macosx High Sierra 10.13.6

Best to all! Rico

edit flag offensive delete link more

Comments

Hallo I had the same on Mac OS X 10.11.6 and LibreOffice 7.1.3: I had to TICK the box before the langpack installation worked,

Asmilwho gravatar imageAsmilwho ( 2021-05-13 18:41:42 +0200 )edit

Question Tools

3 followers

Stats

Asked: 2021-02-06 14:13:14 +0200

Seen: 830 times

Last updated: Mar 30