Can't dock sidebar

Try to reset your user profile. How to do that you will find here. Before storing your existing user profile under a different name.

Thanks. That solved it

If my answer did solve your problem, please click the big checkmark inside the circle to the left of my answer. It then indicates to the other participants that the question has been answered correctly.

Although it does solve the problem, it’s not “a solution”. If the only way to dock an (accidentally or not) undocked sidebar is to reset one’s whole user profile, which means losing all your customizations, that’s quite a major bug! There is a “Dock” item in the sidebar’s contextual menu and it doesn’t do anything :s

@localhost (And for anyone else that encounters this) - I just had the same thing happen. The sidebar came undocked and refused to re-dock. I was unwilling to reset my profile. I ended up closing and re-opening LO and at that point the sidebar, while still undocked, would then dock correctly.

Closing LO allowed me to get the sidebar to respond to the dock command in WinX, but had to shut down all instances of LO. I had Draw and Calc up, and closing only Draw was not enough. I had to close both Calc and Draw…

@AndonRT Your suggestion just solved the issue for me. I just had it happen in Calc last night and it refused to redock. I tried it again this morning with the same problem. I didn’t like the idea of resetting everything, but your solution was perfect. Thanks…and upvoted.

This work on Windows (so adapt accordingly):

Select the Sidebar (you can press F11) then press Ctrl+Shift+F10 (to dock the toolbar). I can’t find this shortcut in the customize menu.

Tested on LibreOffice 7.0.6.2 (x86 and x64).

Related answer: Find toolbar is hiding - #5 by LeroyG

Edit: Won’t work if another dialog is open (like Paragraph or Save as). You also can choose Dock from the Sidebar Settings button (three vertical dots).

Hold the sidebar with the mouse and drag it to the right (or left) edge until a gray frame appears. Then release the mouse.

As stated in my question, dragging the window has no effect. I can drag it almost completely to the right and no frame appears

I’m using Windows 10

You should push the sidebar over the right edge!

Steps:
This solved the re-docking problem for me. However, it didn’t work right away.
I have to close all LO instances, including the quick starter, and then restart Writer.
Now both the dragging-to-the-right-edge technique and the Dock command in the Sidebar Setting (the 3 dots arranged vertically) work well.

Causes?
Maybe the bug resides in how LO deals with hibernation.
I often encounter this problem after resuming my NB from hibernation.

Environment:
LO 6.3.5.2 (x64) under Windows 10 (1909)

I experienced the same issue (LO 6.2.2 on Windows 7). Restarting libreoffice helped already though… (that included quitting the running background program).

Same with me: LibreOffice 6.3.6.2 (x86); OS: Windows 6.1.

image description

The “Sidebar Settings” (3 dots arranged vertically) menu has a “dock” option
OS: Gentoo Linux
LO: 6.3.4.2

I got the same issue. I solved it by choosing the option I want to show (Navigator, in my case), click dock, then undock, and then dock again, then finally drag it to the side I want (left side), it became dockable as it should.
Ps: Manjaro KDE; Libreoffice 7.0.4.2

In the event that you cannot see a docking frame appear (as visualised in ebot’s picture above) to assist in docking the Sidebar then it is likely that docking command ‘dock’ the 3 dotted menu bar will also not work. In either case the docking feature becomes unavailable.

In some circumstances simply restarting LibreOffice is not enough. To fix this problem you might try first saving all your work then goto Help menu then select restart in safe mode. Ensure no options are ticked and simply select “continue on to safe mode button.” Exit out of safe mode and restart LibreOffice in normal mode and it should all word again.

This allows you to avoid having to clear your libreoffice user profile.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. That will help other people with the same question. In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Still an issue as of 9/22/21 with LibreOffice 7.2.0.4 on an Apple M1 MacBook Air (Big Sur 11.6)
Regained docking ability after 2nd (possibly unnecessary) quitting-and relaunching LO and setting the Sidebar Dock setting, which had become unset, apparently during the relaunching process - previously I had tried setting it without any apparent effect. Restarting in safe mode was unnecessary in this instance.

I had experienced this problem and couldn’t see a docking frame appearing when dragging the panel over the right border of the window, the 3 dotted menu didn’t work, either restarting LibreOffice.

I could dock the Sidebar by pressing CTRL on the keyboard while double clicking on an empty area of the Navigator’s icon’s bar. The image shows in red the areas that doesn’t dock, in green is the area that worked for me:
Screenshot_20211002_094726

OS: Ubuntu 20.04
LO: 6.4.7.2