Change selected cell indicator colour (Calc)

It’s nearly impossible to see which cell is selected if the background colour of the selected cell and the ones around it is black, apart from holding two rulers to the screen and checking with the highlight at the top and left. How do I change this colour?

What I tried:

  • Enabling “automatically detect high-contrast mode of operating system” in accessibility settings did of course nothing, because I don’t have such a theme active.
  • Changing “document background” in “application colours” settings instead of editing the default style somewhat works, because the dark cursor is then much more visible, as a gap in the white grid lines, but that neither looks good, nor does it help for any case except if every sheet in every document is supposed to be dark themed. Not even I want that.
  • This post has no working answers, is wrongly closed (as duplicate of an unrelated question) and was asked in 2012 (last active 2016).
1 Like

Afaik no way doing this on LibreOffice application level, since highlight selected-color is determined by the operating system’s windows manager and its theme colorization.

It seems like LibreOffice actually adjusts even the displayed document colours to the system theme. Unless this breaks some documents (which were created on computers with light themes), leaving a dark theme enabled could actually be a solution then. With that, the cursor is visible. It’s a white border among white borders and seems thinner than in the white theme, but it is different enough from regular borders that the eye can jump to it fairly quickly. Edit: It only works with “detect high-contrast mode” enabled. And if that is on, then colouring cells manually no longer works, only conditional formatting/styles.

I think the theme does make it cumbersome on many operating systems. However, I was able to get the darker cell borders when highlighted by changing the Font Color to black. This is found in Options -> Application Colors -> Font color. I am using KDE Plasma. See pictures attached. I hope this helps.

White Border

Black Border

1 Like

Wow, that is weird! But since the font colour should usually be white anyway if the background is black, that’s fine. Thanks for finding out, too bad I mostly stopped using LibreOffice since then. :smiley: But it will surely help others who find this post later.

Alternate Solution: Change the colour of the borders of all other cells. I usually use blue. The selected cell alone remains black! (i.e. Default style Border color: Blue)