Dark Mode Text is Black - Can't Change?

I’ve just updated to the latest version of LibreOffice. I was thrilled to see they’ve implemented dark mode. However, even though within the settings in preferences I have text set to white, I’m ending up with a grey background and black text. How do I get the text to appear white so I can actually see it?

Please paste here the information on Menu/Help/About LibreOffice (There is an icon to copy).

I don’t know what you mean.

See More details, This is the guide - How to use the Ask site? - #3 by Hrbrgr

Version: 24.2.0.3 (X86_64) / LibreOffice Community
Build ID: da48488a73ddd66ea24cf16bbc4f7b9c08e9bea1
CPU threads: 10; OS: macOS 14.3; UI render: Skia/Metal; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

I don’t know if this works correctly on MacOS but

I have everything labeled font in that menu as white, but all the text is still black.

[Redacted by @LeroyG answer to @LeroyG that now is off topic]

Don’t change individual elements, just select the Dark on the drop down box in the picture. If your system is set to dark then you could instead select System theme.

You might want to set all your recent modifications to the light theme back to original so that the light theme can work.

[Redacted by @LeroyG answer to @LeroyG that now is off topic]

When I did that, the background went grey and the text went black.

You might need to restart LibreOffice to see correct colours,
Bug 156855 - Applying to light/dark from LibreOffice → Preferences > View doesn’t properly refresh the UI until restart. (macOS)

1 Like

When I restart, it goes back to the light settings. If I change it to system settings (which are dark) or dark, I still get the grey background and majority of the text is black, while just a few sections (and sometimes just individual words) are white. I have no idea why some sections appear white while others don’t. As far as I can tell, everything about the text is the same.


If you have set the font colour from Automatic toBlack in your paragraph or character styles, or you have direct formatted the text to Black, then it will display as black on screen.
You can read more about styles in the Writer Guide, download from English documentation | LibreOffice Documentation - LibreOffice User Guides

I am surprised that the Dark setting was not saved, did you close LibreOffice before shutting your computer down?

I’ve reset everything, so haven’t changed the font colours. All I’m doing is trying dark and system theme, and I’m getting grey background with black text (with some small sections that are white). Yes, I closed LibreOffice before shutting the computer down. Every time I open a new document, my preferences are gone and it’s back to light.

Reset can have a particular meaning so I am not sure what level of reset you did, or what you reset.
All your font colours in your document should be set to Automatic for them to change appearance with dark mode. If you set the font colour to White it won’t print anything; if you set the font colour to black, it will appear black in dark mode.


Why don’t you try the factory settings in System Theme instead of changing the individual items? It seems to be that what you see is that what you set. Try pressing the Reset button and OK.
This is the default settings for system theme that I see:

When I said I reset it, that’s what I mean. I clicked on the reset button in that screen. The scheme is always on automatic (there are no other options), and then the automatic box I’ve tried both system theme and dark, and both are giving me the grey screen with black text.

But now I seem to have another bug. It doesn’t matter if I choose system theme, dark, or light, all of the setting stay the same. I can’t even get a dark mode now. It stays white with black text.

Can you set everything to Automatic?

Try in Safe mode, Help - Restart on Safe mode- Continue in Safe mode. If it works ok in Safe mode then consider resetting your user profile, LibreOffice user profile - The Document Foundation Wiki

I get the same issue in Safe mode. Dark shows up with a white background and black text. System Theme gives me a grey background with black text with some words and some paragraphs in white.

If setting the individual settings to Automatic didn’t work then probably best to report a bug, How to Report Bugs in LibreOffice - The Document Foundation Wiki