External links between spreadsheets on Windows 10 get corrupted

When I set up an SMB with LibreOffice after upgrading their clients to Windows 10 (Pro) I noticed the following issue:
Some .xls files where kept on a flash drive for mobility and secure communication between the offices, which have external links connecting the data between spreadsheets (all on the same flash drive). When opening those files we noticed that the links were not functioning, corrupting all the data from the second spreadsheet onwards. While correcting the links or creating new ones solved the issue as long as the spreadsheet was open, when closing and reopening the links were corrupted again.
While activating in Options the update of external links and setting the necessary folders as secure locations solved the issue for files on the PC itself (even with non-latin characters in the path) the issue persists for the files on the flashdrive, even after setting the macro security to low.
This issue seems to be the same or related with this one, but it seems unprobable that so many years later this issue still isn’t solved.

Any suggestions?

P.S.: I haven’t tried if the links function in .ods format, as the SMB wants to use the MS formats for compatibility reasons.

UPDATE: The issue stopped occuring for a month or two, but has resurfaced. I have confirmed that the same issue occurs also with .ods files, both on external and internal drives. For the linked data to be read the source file has to be open, otherwise I get “REF!” in the target cell (and so also all subsequent cells). I suspect this is a permissions issue, but I cannot find where to change that.

I haven’t tried if the links function in .ods format, as the SMB wants to use the MS formats for compatibility reasons.

Despite all warnings this being a straight way to data corruption, it is repeated ever and ever again… Don’t use foreign formats for daily work, keep your master document ODF only, use foreign format only for data exchange without modifying content in a foreign application and re-importing. This comment is not a statement about the real issue you might face here, though the bug report for #tdf48463 states in comment #17 that this isn’t a bug but a limitation when using .xls format (btw. That’s why the bug report has been closed as RESOLVED NOTABUG), since the details of the access method to flash drive are unclear (at least to me).

I would prefer using .ods, but that is not my call (as that they are still using Windows). Furthermore, this isn’t an issue of non-native format - I have the same issue with .ods files, both on external drives as on the internal hard drive. External data is only read when both files are running, otherwise you get a REF! entry in the cells.