JDK configuration problems for LibreOffice, MacOS 10.13.6

I’d like to install and configure the Java JDK for use with Base, in LibreOffice running on MacOS 10.13.6.

First, I installed JDK 17.0.2 from Oracle’s website using their x64 DMG installer (i.e. the latest installer for MacOS with Intel processor). Installation succeeded, placing the JDK at /Library/Java/JavaVirtualMachines/jdk-17.0.2.jdk/Contents/Home, and that’s the path shown under Java Options in the LibreOffice Advanced preferences. However, I received an error message from LibreOffice (after restarting): “The selected JRE is defective. Please select another version or install a new JRE…

Next, upon further investigation it looks like the 17.0.2 JDK doesn’t work with MacOS 10.13.4, so I needed an older version. Deleted 17.0.2, and installed an older version for MacOS 10.13 found at Download Java for OS X 2017-001. That installed to /Library/Java/JavaVirtualMachines/1.6.0.jdk, with a number of subfolders. Restarted Mac and LibreOffice at this point. Regardless of which folder I select starting in that path (using LibreOffice Preferences>LibreOffice>Advanced), I get the error message “The folder you selected does not contain a Java runtime environment. Please select a different folder.

Finally, using a hint I found in another thread at this forum (from Ratslinger - thank you @Ratslinger) I used the terminal to search for the java runtime file, which was found at /System/Library/Frameworks/JavaVM.framework/Versions/A. Selecting that path (and all higher level folder and subfolders) for LibreOffice in Advanced Preferences still yields the same error message as before: “The folder you selected does not contain a Java runtime environment. Please select a different folder.

If someone can point me in the right direction to get JDK working on this combination of LibreOffice and MacOS I’d be very grateful for your help! Please let me know if there is any additional information needed to address this. Many thanks in advance.


Sorry don’t have MAC for testing. However in tdf#135479 it appears Oracle Java 14.0.2 works. Another possibility is AdoptOpenJdk 15.02 noted in this German answer → https://ask.libreoffice.org/t/lo-7-1-macos-jdk-nicht-erkannt/61450/3
That’s all I have currently on this.


@Ratslinger, you said “That’s all I have currently on this.” What you had was exactly what I needed, thank you! Perfect.

The fix was to install AdoptOpenJDK 15.05 as you suggested. For anyone looking for that, I found it at: Archive | AdoptOpenJDK - Open source, prebuilt OpenJDK binaries


The links to AdoptOpenJDk will not change in the next time, but please note that Adoptium will replace the former name:

Just a quick note to confirm that @Ratslinger’s advice from earlier, using AdoptOpenJDK 15, works for LibreOffice JDK issues on an M2 Mac in November 2023. I used the link from @mcinnisp’s post. It resolved the Java runtime environment detection for me.

System Details:

Mac with M2 chip
macOS version: Sonoma 14.2 Beta
LibreOffice version:
AdoptOpenJDK version: 15.05

Running macOS 11.7.10 on a mid 2015 MacBook Pro I downloaded and installed Version 8 Update 401 (filesize: 88.59 MB) Release date: January 16, 2024 from https://www.java.com/en/download/ and was then able to start LibreOffice Base. Installation was easy-peasy, and I didn’t hve to do anything else in order to get Base to open a file I created with the wizard. (I haven’t tried to use it yet, however.)

Mac System Requirements for Oracle Java 8 and later versions

  1. X64 based macOS platform running versions 10.8.3+

  2. Administrator privileges

  3. Only 64-bit browser only (e.g., Safari)

Ref: Oracle JDK 8 and JRE 8 Certified System Configurations