Impress won't execute link in Powerpoint file (Windows 11)

I have a PowerPoint presentation that I recently ported to my new Windows 11 laptop where I don’t have PowerPoint installed. When I try to run it with Impress, it fails to run my built-in links that should open Audacity and play a specified audio file. It says “Windows cannot find …” Wish I could include a screenshot.

Cannot find what? The audio file? The Audacity software?
The Audio file is embedded or linked in the presentation file?
Can you upload sample files (but not images only) here?

The embedded hyperlink is: file:///C:/Program
Files/Audacity/audacity.ece ./Week1Sounds/AMWO_PFGECBS_Track_9.wav

I am unsure of the “file:///” preamble, but that is the way it is in the
original PowerPoint file which worked just fine on my old Windows Vista
laptop which contained the Microsoft PowerPoint app.

I have verified that the audacity.exe is indeed in Program
Files/Audacity of my C drive, and that the bird sound .wav file that is
handed to Audacity is indeed in the same directory as the Impress file
in the stated subdirectory.

Hope this helps.

Can’t figure out how to upload files beyond attaching a screenshot of
the failure message, but can report that I am able to create a hyperlink
that successfully opens Audacity (upon clicking on the icon) in my
Impress presentation. Then I could manually feed the target .wav file
into Audacity, but I cannot seem to pass that target directly as an
Audacity command line parameter as I did in PowerPoint.

Screenshot.odt (200 KB)

A context: Impress hyperlink to an executable with its commandline argument

Someone thought the arrow upwards would give a hint to upload:
Seventh symbol from left in the editor here, right from </>
See “How do I add to my question?” in

file:/// is the right start to reference a file in your filesystem, but using this for a complete command-line is stretching the concept of hyperlinks beyond its definition.
The second problem will be the . in the path referencing the current or working directory, wich makes assumpions on how the file was opened and may not work always
As third point security should be mentioned: Executing a command-line by hyperlink should only be allowed with the same precautions as using macros. So I hope a modern Powerpoint on Win11 will not execute your old sheet. (But I’m not sure. MS is known to prefer convenience over security often…)
So use a direct absolute link to your files as the link by @mikekaganski already suggests.

Thank you Wanderer for all three points. I have tried it with and
without the “file:///” preamble in the command line argument and with
the full pathname instead of the “.” shorthand, all to no avail. And,
BTW, Impress does issue a security warning at execution and I accept the
risk because everything involved is known and trusted files within my
I may keep experimenting, but at this point I am inclined to search for
a VGA-to-HTML cable that would allow me to use my old laptop with its
true PowerPoint app. Thanks again.

One more update: I just discovered that if I create a hyperlink
“document” to a sound file, and set Audacity as the default app for
opening such files, it works just fine without ever having to mention
Audacity in the hyperlink. And it avoids causing Impress to issue a
security warning each time. Perhaps you could hear my great sigh of
relief. Thank you for all your insight.

1 Like