Libre Office Vanilla prints in Landscape even though it's set to Portrait

Libre Office Vanilla prints in Landscape even though it’s set to Portrait: The print preview is correct, but the actual printing is Landscape.

MAC OS Sierra 10.12.4
Libre Office Vanilla

Open doc in Libre Office (Non vanilla) prints fine.
Workaround: Change page format to 8.51 x 11.00 and it works.

My guess is the LETTER page format is busted.

Whenever you have the slightest chance tu pull it through:
Use internationally standardised paper sizes. Deprecate the outdated US sizes. Even the UK switched to the international standards.
See: Paper size - Wikipedia,

I had this problem when I upgraded to I went back to and all is well on Sierra 10.12.6 link text

Issue persists in Mac OS 10.12.6 and Libreoffice I reset the printing system and that seemed to fix the problem. Go to system preferences, printers & scanners then right click (control click) on one of the printers in the column on the left. Then select: Reset Printing System

Oh darn! I thought it worked, but I brought up a document in which I had already applied the Workaround described above. Set page format to 8.51 x 11.00. Now I’ve created a template for all documents, so I don’t have to go switching the page format on every project. Guess we’ll wait for the next version…

Same problem with my new running on MacOS 10.11.6 Preview shows portrait, Print popup shows landscape and that’s the way it prints. :frowning:

I changed paper size to 8.49x10.99 and now the Print popup shows portrait.

Build ID: 686f202eff87ef707079aeb7f485847613344eb7
CPU Threads: 4; OS Version: Mac OS X 10.9.5; UI Render: default; Layout Engine: new;
Locale: en-US (en.UTF-8); Calc: group

As hes8 says, I also see portrait when doing File > Print Preview, but the mini-preview in File > Print is in Landscape, as is the printed copy. The mini-preview is in Landscape even when no printers are defined, as is the case after doing ‘Reset printing system’.

8.49x10.99 works for me. Thanks!

Having the same problem with US Letter size on macOS Sierra version 10.12.6 and LibreOffice 5.4. This is super annoying! Please fix this problem!

For the time being, the user size 8.51 x 11.00 kluge/workaround worked for me too.

I too am having this problem, and it’s not the printer as PDF will print fine. (7 August 2017)

The problem seems to relate to LETTER page format. The workaround (mentioned in comment 14 of tdf#92190) is to slightly shrink the page size in LibreOffice.

See also:

Thanks - shrinking the page worked like a charm - and so simple!

Thanks - shrinking the page worked like a charm - and so simple!

Didn’t start having this problem until I upgraded to Libre Office Went to Print Preview > Format Page > Page and changed the 8.5" x 11" Letter format to 8.49" x 10.99" (User).

So is this a “fix in every document” solution or can it be a global change?

Changing the letter format from 8.5 x 11 to 8.49 x 10.99 seems to resolve this issue for me, on my Mac.

But this issue really needs to be fixed upstream, in the source code…

You can do that with the spreadsheet. How can you do it with Writer?

@_rocknation1 posted a workaround which does fix the printing for the particular Writer document that you’re working on.

Unfortunately, this change to reduce the size of the page from 8.5" x 11 to (8.48" x 10.98") does NOT persist, so you would have to re-set this for every document before you print it!

This is pretty much a showstopper for me, so I tried a couple of older LibreOffice versions, 5.3.5 and LibreOffice 5.3.5 also has the same printing bug. LibreOffice does NOT seem to have this printing bug. At least, the print preview looks kosher to me.

I got the version of LibreOffice from here:

Older versions of LibreOffice

I’m not sure why this bug has NOT been fixed yet. It looks like a showstopper to me…

BTW, this printing bug shows up on my Mac computer, running El Capitan. Interestingly, the latest 5.x version of LibreOffice on my Linux machine prints fine.

I do not understand for what reason the people and the authorities of the USA did not abandon the outdated US paper sizes and switch to reasonably defined and internationally standardised sizes decades (or a century) ago. Even the UK did in 1967. That’s half a century now, after all!

(Concerning the recent edit of this non-answer.)
@ginobean: “BTW, this printing bug shows up on my Mac computer, running El Capitan. Interestingly, the latest 5.x version of LibreOffice on my Linux machine prints fine.”
Yes. It was reported more than once that the issue is specific to the Mac (OS X). If I remember correctly some also reported it to only occur with US paper formats. Without access to a Mac I cannot test.
(The ‘Vanilla’ version is not maintained by tdf itself.)

It is not unique to MacOS or to US paper sizes. With Ubuntu 16.04 and LO, I have this problem. None of the work-arounds discussed in thread here make any difference. I cannot print on 9x12 in portrait mode. I cannot print on A4 paper in landscape, even though my printer feeds A4 in landscape from the feeder (I can feed A4 in portrait through the manual feed tray.) Snide comments about standards are all very well, but many people have good reasons to want to use other paper sizes.