Libre Office Vanilla prints in Landscape even though it's set to Portrait

Oh darn! I thought it worked, but I brought up a document in which I had already applied the Workaround described above. Set page format to 8.51 x 11.00. Now I’ve created a template for all documents, so I don’t have to go switching the page format on every project. Guess we’ll wait for the next version…

Same problem with my new running on MacOS 10.11.6 Preview shows portrait, Print popup shows landscape and that’s the way it prints. :frowning:

I changed paper size to 8.49x10.99 and now the Print popup shows portrait.

Build ID: 686f202eff87ef707079aeb7f485847613344eb7
CPU Threads: 4; OS Version: Mac OS X 10.9.5; UI Render: default; Layout Engine: new;
Locale: en-US (en.UTF-8); Calc: group

As hes8 says, I also see portrait when doing File > Print Preview, but the mini-preview in File > Print is in Landscape, as is the printed copy. The mini-preview is in Landscape even when no printers are defined, as is the case after doing ‘Reset printing system’.

8.49x10.99 works for me. Thanks!

Having the same problem with US Letter size on macOS Sierra version 10.12.6 and LibreOffice 5.4. This is super annoying! Please fix this problem!

For the time being, the user size 8.51 x 11.00 kluge/workaround worked for me too.

I too am having this problem, and it’s not the printer as PDF will print fine. (7 August 2017)

The problem seems to relate to LETTER page format. The workaround (mentioned in comment 14 of tdf#92190) is to slightly shrink the page size in LibreOffice.

See also:

Thanks - shrinking the page worked like a charm - and so simple!

Thanks - shrinking the page worked like a charm - and so simple!

Didn’t start having this problem until I upgraded to Libre Office Went to Print Preview > Format Page > Page and changed the 8.5" x 11" Letter format to 8.49" x 10.99" (User).

So is this a “fix in every document” solution or can it be a global change?

Changing the letter format from 8.5 x 11 to 8.49 x 10.99 seems to resolve this issue for me, on my Mac.

But this issue really needs to be fixed upstream, in the source code…

You can do that with the spreadsheet. How can you do it with Writer?

@_rocknation1 posted a workaround which does fix the printing for the particular Writer document that you’re working on.

Unfortunately, this change to reduce the size of the page from 8.5" x 11 to (8.48" x 10.98") does NOT persist, so you would have to re-set this for every document before you print it!

This is pretty much a showstopper for me, so I tried a couple of older LibreOffice versions, 5.3.5 and LibreOffice 5.3.5 also has the same printing bug. LibreOffice does NOT seem to have this printing bug. At least, the print preview looks kosher to me.

I got the version of LibreOffice from here:

Older versions of LibreOffice

I’m not sure why this bug has NOT been fixed yet. It looks like a showstopper to me…

BTW, this printing bug shows up on my Mac computer, running El Capitan. Interestingly, the latest 5.x version of LibreOffice on my Linux machine prints fine.

I do not understand for what reason the people and the authorities of the USA did not abandon the outdated US paper sizes and switch to reasonably defined and internationally standardised sizes decades (or a century) ago. Even the UK did in 1967. That’s half a century now, after all!

(Concerning the recent edit of this non-answer.)
@ginobean: “BTW, this printing bug shows up on my Mac computer, running El Capitan. Interestingly, the latest 5.x version of LibreOffice on my Linux machine prints fine.”
Yes. It was reported more than once that the issue is specific to the Mac (OS X). If I remember correctly some also reported it to only occur with US paper formats. Without access to a Mac I cannot test.
(The ‘Vanilla’ version is not maintained by tdf itself.)

It is not unique to MacOS or to US paper sizes. With Ubuntu 16.04 and LO, I have this problem. None of the work-arounds discussed in thread here make any difference. I cannot print on 9x12 in portrait mode. I cannot print on A4 paper in landscape, even though my printer feeds A4 in landscape from the feeder (I can feed A4 in portrait through the manual feed tray.) Snide comments about standards are all very well, but many people have good reasons to want to use other paper sizes.

(repost of an answer to a similar question)

MANY MANY PEOPLE have been troubled by this longstanding, work-stopping MacOs LibreOffice bug … including my spouse at 2:00 am.

Here is a clean workaround (which I found by exhaustive testing).

The chief advantage of this workaround is that it requires NO changes to the document itself—hence, no future changes will be required, if-and-when some future LibreOffice release fixes this bug.

• MacOS: works for both 10.11.6 (El Capitan) and 10.12.6 (Sierra)

• LibreOffice: works for both 5.3.6 and 5.4.2

  1. Call up the print dialog for a “Letter” text document by the usual method, namely “File” → “Print”

  2. If necessary, select the menu item “LibreOffice” (other choices in this menu include “Layout”, etc.)

  3. Two tabs will be visible now: namely “LibreOffice Writer” and “More”; select the tab “More”

  4. Now a menu will be visible, whose choices include “All Pages”.

  5. (Here’s the “magic”) select ANY menu item OTHER than “All Pages” … then reselect “All Pages”.

The net effect SHOULD be nil … but instead, this sequence will trigger a refresh of the entire dialog box … and the refreshed box will display a now-correct “Portrait” mode.

Problem solved … but alas, this workaround must be applied anew for each new print job.

Hopefully this work-stopping LibreOffice bug—a bug of several years’ standing—will be fixed sooner rather than later.

Tried this fix but it did not work for me.

I tried this fix, and it did reorient the page but it now the print dialog only sees one page to print (in this case page 2). And it only prints that one page. My husband suggests installing WINE and using LibreOffice for Windows but that seems like too much embedding. Also, I’ll need to disable Gateway temporarily to install WINE which makes me nervous. For now, I’m saving my LO documents as docx then opening them in Pages to print out, which seems a little ironic, but at least it’s working!

this works