LibreOffice Writer adding page breaks when using Mail Merge


I recently started using LibreOffice Writer and I have a template which I fill with data from ods file using Mail Merge function.
Before I print I always click Edit Individual Documents and then print.
And the problem is that for some weird reason it automatically adds page breaks.
It wouldn’t be problem to remove like 5 or 10 of them, but I am dealing with around 200 pages so I can’t remove them manually.

Here are the files:
test.odt (27.5 KB)
test_database.ods (38.6 KB)

Anyone knows why this is happening?
Thanks for help!

Please complete your description (edit initial question!).

You have a source document for the form letters, that has how many pages?
How many form letters are created in total?

Probably your source document is not formatted correctly.
Please anonymize it and upload it here so someone can look at it and examine it. Thank you.

I edited the question as you pleased.

Stop printing blank pages.

Printing labels (File → New → Labels) instead of using tables might also be helpful.
Etiketten.odt (31,8 KB)

1 Like

Thanks, it worked. I also tried the Labels approach but it didn’t get rid of page breaks.

But at least there are no more labels missing at the transition :grinning:

Well, while your’s document don’t lose any, I have created a new from scratch using File -> New -> Labels and it still misses one between. Am I missing something?

You may have inserted the next record field more than once (as happened in the example file test.odt).

1 Like

Nope, in my file which I am working in there is only one Next Record at the end.
Idk, but I don’t have that Synchronize Labels which is present in your document.

Use the

Tab “Options” “Synchronise contents” check mark.

1 Like

Okay, but how can I access this menu if I already created Labels?

The Synchronise Labels button is only visible in the document if you selected the “Synchronise Contents” option in the “Options” tab when ! creating the labels !.

1 Like

Thanks, but Synchronize Labels changes some things a little bit.
First it adds some weird smaller boxes.

And second every box except the first one is read-only.

First it adds some weird smaller boxes.

This can actually only be the case if there is something in the first upper left label.
(The box looks like a section has been inserted. Menu Format>Sections, there you can delete it.)

And second every box except the first one is read-only.

That is the purpose of the synchronization. You just have to change in the first upper left label and then click the “Synchronize Labels” button.

Sometimes it is better to read something beforehand and then try it out.

Address labels in Writer

1 Like

You can also unblock it.

1 Like

Okay It finally worked, thanks you.