Not getting data onto label master

I have to print off 51 labels for a society dinner. I am using an .ods spreadsheet, and BASE for the database everything looks good on the setup and the label sheet in writer, but when I print (paper, screen, or .pdf, I get just the formats. I have attached a 7zip file of the documents. I am using windows 10 Build 19041 (64 bit) and LibreOffice
Here is an update of my methodology:
I have been trying for 3 days to get address labels printed. I have read the documentation and watched several videos.

1 I have downloaded a new copy of Libreoffice 7 and installed that instead of the portable version I had been using. 
2 I am using Windows 10 build 19041 (64 bit) and LibreOffice (64) with Java (64) installed.
3 The system works with the user data database.
4 The directory everything is in is called address labels.
5 The spreadsheet is called address.ods
6 I open the spreadsheet to the sheet membership
7 Next I opened the new database wizard 
    7.1 Create a new database
    7.2 Select spreadsheet
    7.3 I select next and browse to the directory and select address.
    7.4 I select save and proceed and save the database.
8 I have saved the database to the same directory so that there is no problem with locating in different directories.
    8.1 I have tried both same and different directories and there is no change in the lack of success.
9 I next go to file /new/labels
10 I make certain the “Address” block is unchecked.
    10.1 I had made this error in the past but even corrected does not work.
    10.2 I select labels Database
    10.3 I select membership for the table (there is only one table)
    10.4 I have selected FullName, Address1, City, State, and zip
    10.5 Placed line breaks at end of Fullname and Address1 to get the labels to format correctly
    10.6 I selected sheet
    10.7 I selected Avery Letter Size
    10.8 I selected 8160 which is an Avery standard
    10.9 I press new document and the labels.odt document appears
11 The Formated labels document with the fields intact showing the field names in proper position and spacing.
12 When I print the new .odt only has the field names.
    12.1 I have tried printing with the internal pdf 
    12.2        I have tried with the cutewriter for pdfNeither of these gets the fields populated.
13 I have closed all files and reopened them
    13.1 I checked tools > options \ LlibreOffice >Base > databases
    13.2 I checked the database labels and it has the membership table and it is populated.


Your files seem to contain personal information. I have deleted those files. When posting use artificial data.

Your database contained no information. You never created or linked to a database based upon the spreadsheet. That is the problem. If that is done and (based upon your documents) the labels work when the database is registered with the name “New Database” (your name used not mine).

Thanks for the adjustment. I don’t understand why I don’t have a connection. I saw several videos (which I usually don’t do) and followed the documentation, I can load the db fields but they never seem to poulate. Any suggestions.

Based upon the files I downloaded (before deleting from question) the database is empty. With this it is difficult to tell where your problem is. First check registered databases. From Menu Tools->Options. Then under LibreOffice Base->Databases on the right is registered databases. The sample you provided was using registered name of New Database. Find that DB on your system and open it and see if there is data in the table. If not it is not created correctly.

Thanks for the help so far. I have checked under both Tools>options and LibreOffice>base>databases and the database is there. Also when I open Base I find the database and open the table to find the fields populated. I would like to attach a visual copy of my work but can’t find a way to do that in comment.

Just edit your question (lower right corner). Also note it is an edited section such as

Edit 2021-05-17:

My new information here.


It appears you are missing a step.

It is immediately after #11 - that is to actually select the records to print.

See this post → Labels not printing

Thanks that got me to thinking -
The solution is exceedingly simple yest the system is confusing. When you print the labels the system recognizes that you have labels and asks if you want to print a letter (?). If you press no you get just the field names. Pres yes and you get the labels.
This should be marked closed.

However I thank you for the help, sometimes we just have to have a second set of eyes/ears/ thoughts to see the simple step we are missing.