Base Issue: No Java installation could be found

I am getting the same error that I have found several posts commenting on. “No Java installation could be found. Please check your installation.” I get this error on both of my machines (iMac and Mac Air) both running MacOS Montgomery 12.3.1 and LibreOffice Version 7.3.3.2 and Java JDK version 18 64bit. I have also ensured that Under Preferences->Advanced->Use a Java runtime environment is enabled and Oracle Corporation 18.0.0.1 is enabled (circle is filled in).

I have also tried uninstalling Java and Libre and installing Java first and the4n restarting and then installing Libre but still get the same error. This error happens on existing databases and also on newly created ones once I click on Tables.

Can someone point me in the right direction? The screenshot below show the preferences in Libre.

Not an answer, just something that confused me:

Is there a “Montgomery”?

You have two versions of JDK installed. I seem to remember that there was a problem with JDK 18 until recently (I believe the fix not yet released). Can you try JDK 17?

(Or maybe 19de5d97efbb80e9767bc6b873bcc2c263a721de - core - Gitiles was only about building … anyway, trying wouldn’t hurt I suppose)

Some hints from other posts, which I can’t find at this moment.

For Mac the whole Java installation is needed, not only JRE.

The original Java form Oracle will work, OpenJDK won’t work.

Note that after tdf#124503, we will likely support other vendors as well; prior detection problems could be due to the typo mentioned in af9ae2d6a968656208528144e5f01b17b383126c - core - Gitiles.

LOL autoNOTcorrect! I meant Monterey

I removed version 18 and also tried removing both 17 and 18 and then reinstalling 17 and still got same issue all versions installed from Oracle not Open

Here some links about MacOS and Java directly fron ask.libreoffice.org
Java for LO 7.3.0.3, JDK instead of JRE, Oracle Java or OpenJDK?

Yes these links are the same I have been to before. I have ensured I have JDK and it is from Oracle and LO is 7.3.3.2 and Java JDK 64bit Intel version 17.0.3.1

Is it an Apple Silicon package? If so, respective Apple Silicon build of Java would be required…

I double checked and both Java and LO are Intel 64bit installs which matches the intel based chip my system has (iMac Intel Core i5)

Does anyone else have any suggestions please? I am still unable to create or use Base. Thank you

Just an observation on one of my computers: When starting LibreOffice, I have to wait until the spinning wheel (loading) stops, before doing anyting. Otherwise I can’t acess anything wich needs java, but all other functions work.
Then I need to close all LO-Windows and open them again - usually the database first. Don’t know, if this can happen on your Mac.

Having the same issue. I teach a database class and my students with MACs are downloading the lastest Oracle JDK (version 18) and 7.2.2 LO and experiencing the issue. In doing some debugging, it appears to be the JDK as I have an old JDK (version 10) that will work with the new 7.2.2. It is odd that when you look in Preferences->Advanced in LO, the JDK shows up and is enabled yet, the database cannot connect to it. Students with Windows systems are not having any issues.

I encountered the exact same problem with LO 7.3.3.2 and Oracle JDK 18 (AMD 64-bit) installed on OSX Monterey 12.4 with an Apple Silicon chip as described by MrCleanTimelord. Installing various older JDK versions did not solve the problem nor by Intel x64 JDK versions. With the Azul JDK 18 (AMD version) the message “No Java installation could be found” disapeared and everything works now perfectly.

https://www.azul.com/downloads/?package=jdk#download-openjdk