DDE link not working 7.4.5

My Calc DDE links were working fine until I updated to 7.4.3, but once updated the cell is blank
I was told that the issue would be fixed in version 7.4.5
Have upgraded to 7.4.5 but still have the same problem.
I have gone to the help files which states:

=DDE(“soffice”;“c:\office\document\data1.ods”;“sheet1.A1”) reads the contents of cell A1 in sheet1 of the LibreOffice Calc spreadsheet data1.ods.

My syntax is =DDE(“soffice”,"/home/mike/Downloads/Untitled 1.ods",“sheet1.A1”)
Cell A1 in sheet1 of Untitled 1.ods contains a value of 121.35, but I get a blank result

The only difference is the semi-colon is replaced by a comma
I am on Linux, the path was copied from file properties.

Will be fixed in version 7.5, officially released next Monday.

Already available.


Fwiw, that is the release candidate that will become the released version if nothing goes wrong. It’s not officially released yet.

Agree, it’s not officially released.

Have downloaded 7.5 - still the same problem

Then please file a separate bug, with your sample file; CC me there, and I’ll try to see what’s wrong there.

Did you install it?


Do I need to create bugzilla account for this, have not had to do this before

To submit a bug you need an account there, yes.

Target.ods (15.6 KB)
source.ods (14.9 KB)

You can create a DDE link dragging a cell range from the source document into the target document and drop it with Ctrl and Shift keys being pressed.
You get an URL link when you paste-special a copied range with “Link” option.

Have retried the link and it is now working,

Not in 7.4.5, but in 7.4.6: tdf#152717


The whitenoard there currently (2023-02-12 12:55:46 UTC) states “target:7.6.0 target:7.4.6 target:”. This includes reported here as NOT working as expected. How to understand?

Just tested: For me (LibreOffice Calc under Win 10) the example provided with the bug report (just everything moved to a different folder) works as expected. The fix for seems to be OK.

As a possible overlook on my side, when the said fix didn’t cover some specific case. Quite plausible. That was why

As far as I can see no comment or answer yet was related to this statement. The supposed bug behind the issue, announced to be fixed soon wasn’t linked-in by anybody. @mikekaganski did.
Strange! Therefore:
I did not check if the OriginalPoster’s issue is related to that bug, but:
Generally: The semicolon is still accepted by all versions of LibreOffice Calc under any locale as the argument (‘function’) delimiter (This is NOT about Basic code, of course!). You should always prefer the semicolon in this role, and you can get your Calc to also display it in the cells and in the FormulaBar.
>Tools>Options>LibreOffice Calc>Formula>>Separators>Function:
Enter a semicolon there.
Once again: Even if you have a comma there due to the defaults for your locale, the semicolon is accepted (though replaced by a comma then for the local version of the formula).
See also: Why do I often get an error (508, 504, 502 e.g.) if I paste a Calc formula from some post into my sheet?