Pergunte aqui

Histórico de revisões [voltar]

Dialogo não mostra imagens.

Alguém saber explicar o que esta errado ou é bug ? Uso Win7(64) + Libo 6.0.4.2(x64)

Edição do Dialogo

Descrição da imagem

Visualização com Caixa de dialogo de visualização

Descrição da imagem

Minha macro:

'====================================================================
Sub ExecutarMiDialogo
'====================================================================
Dim oDialogo As Object
Dim oDialogoModelo As Object
    DialogLibraries.LoadLibrary( "Standard" )
    oDialogo = CreateUnoDialog( DialogLibraries.Standard.getByName("DiaMenu") )
    oDialogoModelo = oDialogo.getModel()
    With oDialogoModelo 
        .PositionX = 20                 'Posição a partir da esquerda.
        .PositionY = 20                 'Posição a partir do topo.
    End With
    Beep    
    oDialogo.execute()
    oDialogo.dispose()  
    Beep
End Sub

Executando a macro as imagens não estão visíveis.

Descrição da imagem

Dialogo não mostra imagens.

Alguém saber explicar o que esta errado ou é bug ? Uso Win7(64) + Libo 6.0.4.2(x64)

Edição do Dialogo

Descrição da imagem

Visualização com Caixa de dialogo de visualização

Descrição da imagem

Minha macro:

'====================================================================
Sub ExecutarMiDialogo
'====================================================================
Dim oDialogo As Object
Dim oDialogoModelo As Object
    DialogLibraries.LoadLibrary( "Standard" )
    oDialogo = CreateUnoDialog( DialogLibraries.Standard.getByName("DiaMenu") )
    oDialogoModelo = oDialogo.getModel()
    With oDialogoModelo 
        .PositionX = 20                 'Posição a partir da esquerda.
        .PositionY = 20                 'Posição a partir do topo.
    End With
    Beep    
    oDialogo.execute()
    oDialogo.dispose()  
    Beep
End Sub

Executando a macro as imagens não estão visíveis.

Descrição da imagem

Salvando o arquivo, na abertura na edição as imagens sumiram....

Descrição da imagem

Dialogo não mostra imagens.

Alguém saber explicar o que esta errado ou é bug ? Uso Win7(64) + Libo 6.0.4.2(x64)

Edição do Dialogo

¿Alguien sabe explicar lo que está mal o es un error? Uso Win7 (64) + Libo 6.0.4.2 (x64)

Edición del diálogo

Descrição da imagem

Visualização com Caixa de dialogo de visualização

Visualización con cuadro de diálogo de visualización

Descrição da imagem

Minha macro:

Mi macro:

'====================================================================
Sub ExecutarMiDialogo
'====================================================================
Dim oDialogo As Object
Dim oDialogoModelo As Object
    DialogLibraries.LoadLibrary( "Standard" )
    oDialogo = CreateUnoDialog( DialogLibraries.Standard.getByName("DiaMenu") )
    oDialogoModelo = oDialogo.getModel()
    With oDialogoModelo 
        .PositionX = 20                 'Posição a partir da esquerda.
        .PositionY = 20                 'Posição a partir do topo.
    End With
    Beep    
    oDialogo.execute()
    oDialogo.dispose()  
    Beep
End Sub

Executando a macro as imagens não estão visíveis.

Ejecutar la macro las imágenes no son visibles.

Descrição da imagem

Salvando o arquivo, na abertura na edição as imagens sumiram....

Salvando el archivo, en la apertura en la edición las imágenes desaparecieron ....

Descrição da imagem