Pergunte aqui

Histórico de revisões [voltar]

clique para ocultar/mostrar a revisão 1
Versão inicial

Macro Inserir formula com variável

Ola pessoal, Preciso colocar duas variaveis para linha e coluna ao inserir formula em uma celula. Segue a macro abaixo. Se alguem puder me ajudar agradeco.

Sub calculo Dim oDoc As Object, oPlan as Object, oCelula As Object oDoc = ThisComponent lin = 15 col = 6

while oPlan.GetCellByPosition(4,lin).String<>"" oCelula = oPlan.GetCellByPosition(col,lin)

 oCelula.FormulaLocal = "SOMA(F16*1)"  ' NO LUGAR DE F16 PRECISO COLOCAR UMA VARIAVEL PARA RODAR O LOOP TANTO PARA A LINHA QUANTO PARA A COLUNA. ASSIM DA ERRO : "=SOMA((col,lin)*1)"

Obrigado.

Macro Inserir formula com variável

Ola pessoal, Preciso colocar duas variaveis para linha e coluna ao inserir formula em uma celula. Segue a macro abaixo. Se alguem puder me ajudar agradeco.

Sub calculo
Dim oDoc As Object, oPlan as Object, oCelula As Object
oDoc = ThisComponent
lin  = 15
col = 6

6

while oPlan.GetCellByPosition(4,lin).String<>"" oCelula = oPlan.GetCellByPosition(col,lin)

oPlan.GetCellByPosition(col,lin)
  oCelula.FormulaLocal = "SOMA(F16*1)"  "SOMA(F16*1)"

' NO LUGAR DE F16 PRECISO COLOCAR UMA VARIAVEL PARA RODAR O LOOP TANTO PARA A LINHA QUANTO PARA A COLUNA. ASSIM DA ERRO : "=SOMA((col,lin)*1)"

"=SOMA((col,lin)*1)"

Obrigado.

Macro Inserir formula com variável

Ola pessoal, Preciso colocar duas variaveis para linha e coluna ao inserir formula em uma celula. Segue a macro abaixo. Se alguem puder me ajudar agradeco.

Sub calculo
Dim oDoc As Object, oPlan as Object, oCelula As Object
oDoc = ThisComponent
lin  = 15
col = 6

while oPlan.GetCellByPosition(4,lin).String<>""
     oCelula = oPlan.GetCellByPosition(col,lin)

     oCelula.FormulaLocal = "SOMA(F16*1)"

' NO LUGAR DE F16 PRECISO COLOCAR UMA VARIAVEL PARA RODAR O LOOP TANTO PARA A LINHA QUANTO PARA A COLUNA. ASSIM DA ERRO : "=SOMA((col,lin)*1)"

Obrigado.