Pergunte aqui

Histórico de revisões [voltar]

clique para ocultar/mostrar a revisão 1
Versão inicial

Como resolver o problema do comando copiar de um arquivo para outro ??

Atualmente, usamos o Ubuntu 2 como versão de sistema operacional. Como planilha a versão LibreOffice 4.0 Calc.

Anteriormente, quando criava meus arquivos, utilizava fórmulas, como exemplo a seguir: 1) Fórmula do arquivo original: =+$'Origem Dados'.C69+$'Origem Dados'.C70+$'Origem Dados'.C71 ou =SOMA($Pagamentos.F69:F86)+$'Descontos e PSE'.B4, dentre outras parecidas envolvendo células de planilhas do mesmo arquivo;

2) Copiava para o arquivo posterior, com nome diferente do original, porém com nomes idênticos de planilhas e linhas. A cópia, utilizando control C e control V ou Editar e copiar, trazia as mesmas fórmulas. Mas após mudanças na versão do Ubuntu e do LibreOffice, o comando copiar traz todas informações de endereçamento do arquivo, conforme demonstrado no exemplo a seguir: =+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C69+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C70+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C71 ou =SOMA('file:///home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$Pagamentos.F69:F86)+'file:///home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Descontos e PSE'.B4. Portanto, na reabertura do arquivo, ocorrem inconsistências do tipo #ERR, ZERA a fórmula, ou depende de alterações das células envolvidas nas planilhas.

3) O que está havendo para tais inconsistências. Desculpe caso tenha, por engano, confundindo nomes, pois trabalho na Gestão Financeira, não sou especialista em TI.

Fico a disposição para maiores esclarecimentos. Grato pela atenção dispensada.

Atenciosamente, Mauro A. Faraco SERPRO - Brasilía/DF - Brasil Fone: 55.61.2020-8042 ou 61.9395-1450 Email: mauro.faraco@serpro.gov.br

clique para ocultar/mostrar a revisão 2
No.2 Revision

Como resolver o problema do comando copiar de um arquivo para outro ??

Atualmente, usamos o Ubuntu 2 como versão de sistema operacional. Como planilha a versão LibreOffice 4.0 Calc.

Anteriormente, quando criava meus arquivos, utilizava fórmulas, como exemplo a seguir: seguir:

1) Fórmula do arquivo original: original:

 =+$'Origem Dados'.C69+$'Origem Dados'.C70+$'Origem Dados'.C71    ou Dados'.C71

ou

   =SOMA($Pagamentos.F69:F86)+$'Descontos e PSE'.B4, PSE'.B4,

dentre outras parecidas envolvendo células de planilhas do mesmo arquivo;

2) Copiava para o arquivo posterior, com nome diferente do original, porém com nomes idênticos de planilhas e linhas. A cópia, utilizando control C e control V ou Editar e copiar, trazia as mesmas fórmulas. Mas após mudanças na versão do Ubuntu e do LibreOffice, o comando copiar traz todas informações de endereçamento do arquivo, conforme demonstrado no exemplo a seguir: seguir:

 =+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C69+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C70+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C71   ou Dados'.C71

ou

   =SOMA('file:///home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$Pagamentos.F69:F86)+'file:///home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Descontos e PSE'.B4. PSE'.B4.

Portanto, na reabertura do arquivo, ocorrem inconsistências do tipo #ERR, ZERA a fórmula, ou depende de alterações das células envolvidas nas planilhas.

3) O que está havendo para tais inconsistências. Desculpe caso tenha, por engano, confundindo nomes, pois trabalho na Gestão Financeira, não sou especialista em TI.

Fico a disposição para maiores esclarecimentos. Grato pela atenção dispensada.

Atenciosamente, Mauro A. Faraco SERPRO - Brasilía/DF - Brasil Fone: 55.61.2020-8042 ou 61.9395-1450 Email: mauro.faraco@serpro.gov.br