Nothing works in new install (Windows 7 Pro)

Running WIN 7 Pro. Just installed I see basic menu screen but no items work. Selecting any “new” yields white screen. Opening an existing text document yields black screen. Re-downloaded and reinstalled : no help. Rt click menus appear normal (But, of course, have no targets?) Options menu appears normal but no item is live. Was running a recent version without problems on this box. I have Administrator user status.

Those sound like classic symptoms of the OpenGL bug (causes blank screens if preset or enabled in v4.4) (causes black screens if preset or enabled in v5.0) (is on by default in v5.1) (good grief) (+ causes non-printing of images - see bottom).

From Q61182, the switch is accessed:-

(menu):Tools→Options→View (uncheck use OpenGL)

(menu):Tools→Options→LibreOffice→View (uncheck Use OpenGL + ForceOpenGL) (v5.1)

From Q45801, a slightly more complicated fix is to change one or more of 2 settings within registrymodifications.xcu within the personal profile folder (Q62646) whilst LO is NOT running (below are the values that you want):-

[Windows system drive letter]:\Users\[user name]\AppData\Roaming\LibreOffice\4\user

<prop oor:name="ForceOpenGL" oor:op="fuse"><value>false</value></prop>
<prop oor:name="UseOpenGL" oor:op="fuse"><value>false</value></prop>

From Q61182, an easier, though slightly scary, method is available for Windows by using a reg-file to hack the Registry & switch OFF all OpenGL processing:-

  1. save this file as ‘opengl.reg’
  1. double-click on the file
  2. that’s it! (the Registry editor places those entries into the Registry)

This is what that file from step-1 looks like:

Windows Registry Editor Version 5.00



Update March 11 re: “Unable to Print Images”

The exact self-same issue as above is also responsible for tdf#94851 (“Images are not printed (paper and PDF) with OpenGL activated”) and is fixed by the same methods. See also Q59473.

Patches have been committed to fix this in all versions (2015-12-12), although I am uncertain whether they are any more than switching OpenGL off by default.

Why is the screen on my libre office writer black
Printout is NOT matching preview
Images stretched/warped when exporting to PDF, since newest Libreoffice version
Has Anyone successfully installed on windows 10
Suddenly after years, I can only print text
How do I PDF a LibreOffice document?
Mail Merge Printing Problems
Problem with impress with transition windows 10 LibreOffice 5.0.3
Libreoffice-online doesn't work
I need help getting pictures to print...
Installed 5.1.0 When Open Just see the menu, rest is blank
Libre Office 5 bugs - is it to do with upgrade to Windows 10?
Why does text in rotated text boxes becomes distorted and disappear?
I update the video drivers while LO5.x was open
Black line/letters on top of the paper when printing from Writer
impress transitions blinking
Incorrect graph export as PNG using macros
Opening LiibreOffice docs in MsWord, images are -20% darker
cut/paste from Firefox web site does not display images in Writer 5.0.3 on OSX or Linux
Libreoffice doesn't save content after first inserted image
Writer: pictures are shown in preview, but not printed
The toolbar is all black
Problems printing page in writer.
odts open all black!
LibreOffice 5.0.3 windows are all empty black - Windows 10
LibreOffice behaving strange after font change
Images do not print in
Slide show 2/3 covered with black overlay
trouble with graphics in Intel Iris
Screen becomes black with dotted lines on opening write or Calc in just installed Libreoffice 5 on my Dell note book with Windows 10 just after few seconds. Please help
How can you get rid of black screen when attempting to run Libre Office on Surface productsco
writer 5 how do i view a doc file properly with an embedded font
Photos in document don't show up in printing, only the text. How do I fix this?
impressed by LO5! but pdf importing badly
Why does text not show colour on screen?
Black unresponsive screen after closing files
Images stretched/warped when exporting to PDF, since newest Libreoffice version
LibreOffice Freezing Win Server 2008 xenApp Citrix
How do I stop the page of text from blinking?
A problem with image dpi in LO Draw
Why does LibreOffice for OS X crash after Insert-Image attempt?
Strange word spacing using writer
Missing photos
Printing from Calc: Wrong Characters appear on page (square with ? inside)
Why is Ubuntu 14.04 64 bit LibreOffice unstable?
How do I turn images back on when there is no image icon on toolbar?
How can I fix black or blank screen on LibreOffice 5?
Does impress in libreoffice v5 link or embed pictures and clip art
Since I upgraded to Windows 10 I have been unable to open LibreOffice 5, which I was previously using on Windows 8. Can anyone explain and help?
LibreOffice files do not open after Windows 10 upgrade
New Install of and nothing works
SEH Exception
Newly installed 5.1 opens but is not functional
LO 5.1 on Asus Eee PC 1025C netbook?
New 'feature' in V5.1. On opening, it changes screen colours to a horrible mess.
Images in exported PDFs are sometimes black
My Windows 10 has just upgraded, now I cannot open any documents with Libre Office, all I get is a black Window
Windows 7 and Libreoffice, calc cannot read data from version
LO 5.0 writer, calc printing images

Patches have been committed to fix this in all versions (2015-12-12), although I am uncertain whether they are any more than switching OpenGL off by default.

Last patch (v5.0.5) was 2015-12-14 and the patches were a proper fix to bitmap handling i.e., partly amending internal method use and changing Windows bitmap handling from RGB to BGR.

Many thanks for that addition, oweng.

OK. In an excess of caution I did several things:

    1. ran sfc /scannow 2) ran MSIEXEC
      Unregister and reregister the Windows
      Installer ) 3) Started and stopped
      the Windows Installer Service ,
      confirmed MANUAL status 4) Closed all
      applications 5) Installed 5.103 msi
      executable. Installed Help package.
    2. Rebooted (having not yet opened
      the new install) 7) Opened 5.103
      using Run As Administrator 8) Voila!!

Are you f*cking kidding me? I’ve got to do all that to get an upgrade of an installed piece of software (LO 4.4.3.x) to work? What a piece of sh#t. I guess I’ll try these instructions and report back.

Good grief.

I tried 5.0.5, (beta) both 32-bit and 64-bit of both as well as 32-bit version of 5.1.0. NONE worked. NONE would display. Sometimes the menus functioned, other times they did not (e.g. File > Exit LibreOffice failed to close the window OR exit LibreOffice.)

I re-installed the 32-bit version of LO 4.4.2. At least that still worked.

I tried the fix suggested by Alex but to no avail.
I’m using the 64 bit version on Win 10 and get the access violation on the spreadsheet and drawing utilities, both of which I have used a lot. It happens whenever I try to make any change to a drawing or spreadsheet.

Is there a timeline for the fix? LO is a great tool but I’m going to have to find alternatives. I do not want to manually change the registry.