Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

libreOffice 5.1.3.2 spell checker not working

I'm using libreOffice 5.1.3.2 on a KUbuntu 14.04LTS system with all updates intact. I cannot get the spell checker to work. It says all words are correct. I am English and I'm trying to use English spell check with an English written document. I've been using LibreOffice for a few years on different systems and despite reading in multiple places about it being an old bug, I've never experienced the problem. Now I have the problem on one of the latest versions of the software.

  1. On the sytesm I've reinstalled myspell-en-gb && myspell-en-us

  2. I've purged and re-installed LibreOffice,

    I've checked:

  3. Tools > Options > Language Settings > Languages

  • User Interface: Default-English USA
  • Locale setting: Default-English USA
  • Default Languages for Documents
  • Wester, Asian,& Complex text layout (CTL) checked
  • And checked "Default-English USA, English USA and English USA"
  • "For the current document only" is blank
  1. Tools > Options > Language Settings > Writing Aids
  • Available Languages modules: checked the following "Hunspell SpellCheker, Libohyphen Hyphenator, OpenOffice.org New Thesaurus"
  • User-defined dictionaries: The following are checked "standard English USA, technical"
  • Available Languages modules: The following are checked "Hunspell SpellCheker, Libohyphen Hyphenator, OpenOffice.org New Thesaurus"
  • User-defined dictionaries: The following are checked "standard English USA, technical"
  • Options: The following are checked "Check spelling as you type, check grammar as you type, check uppercase words"
  1. Tools > Language > For Selection > English USA "is checked"
  2. Tools > Language > For Paragraph > English USA "won't let me check English USA"
  3. Tools > Language > For All Text > English USA "won't let me check English USA"

  4. Tools > LanguageTool > Check Text "this is checked"

Update: Trying to click (check) #6 and #7 makes the spell checker work again.

Does anyone know why when I click #6 and #7 a check does not appear in the box, but the spell checker starts working?

libreOffice 5.1.3.2 spell checker not working

I'm using libreOffice 5.1.3.2 on a KUbuntu 14.04LTS system with all updates intact. I cannot get the spell checker to work. It says all words are correct. I am English and I'm trying to use English spell check with an English written document. I've been using LibreOffice for a few years on different systems and despite reading in multiple places about it being an old bug, I've never experienced the problem. Now I have the problem on one of the latest versions of the software.

  1. On the sytesm I've reinstalled myspell-en-gb && myspell-en-us

  2. I've purged and re-installed LibreOffice,

    I've checked:

  3. Tools > Options > Language Settings > Languages

  • User Interface: Default-English USA
  • Locale setting: Default-English USA
  • Default Languages for Documents
  • Wester, Asian,& Complex text layout (CTL) checked
  • And checked "Default-English USA, English USA and English USA"
  • "For the current document only" is blank
  1. Tools > Options > Language Settings > Writing Aids

  • Available Languages modules: checked the following "Hunspell SpellCheker, Libohyphen Hyphenator, OpenOffice.org New Thesaurus"
  • User-defined dictionaries: The following are checked "standard English USA, technical"
  • Available Languages modules: The following are checked "Hunspell SpellCheker, Libohyphen Hyphenator, OpenOffice.org New Thesaurus"
  • User-defined dictionaries: The following are checked "standard English USA, technical"
  • Options: The following are checked "Check spelling as you type, check grammar as you type, check uppercase words"
  1. Tools > Language > For Selection > English USA "is checked"

  2. Tools > Language > For Paragraph > English USA "won't let me check English USA"
  3. Tools > Language > For All Text > English USA "won't let me check English USA"

  4. Tools > LanguageTool > Check Text "this is checked"

Update: Trying to click (check) #6 and #7 makes the spell checker work again.

Does anyone know why when I click #6 and #7 a check does not appear in the box, but the spell checker starts working?

libreOffice 5.1.3.2 spell checker not working

I'm using libreOffice 5.1.3.2 on a KUbuntu 14.04LTS system with all updates intact. I cannot get the spell checker to work. It says all words are correct. I am English and I'm trying to use English spell check with an English written document. I've been using LibreOffice for a few years on different systems and despite reading in multiple places about it being an old bug, I've never experienced the problem. Now I have the problem on one of the latest versions of the software.

  1. On the sytesm I've reinstalled myspell-en-gb && myspell-en-us

  2. I've purged and re-installed LibreOffice,

    I've checked:

  3. Tools > Options > Language Settings > Languages

    • User Interface: Default-English USA
    • Locale setting: Default-English USA
    • Default Languages for Documents
    • Wester, Asian,& Complex text layout (CTL) checked
    • And checked "Default-English USA, English USA and English USA"
    • "For the current document only" is blank
  4. Tools > Options > Language Settings > Writing Aids

    • Available Languages modules: checked the following "Hunspell SpellCheker, Libohyphen Hyphenator, OpenOffice.org New Thesaurus"
    • User-defined dictionaries: The following are checked "standard English USA, technical"
    • Available Languages modules: The following are checked "Hunspell SpellCheker, Libohyphen Hyphenator, OpenOffice.org New Thesaurus"
    • User-defined dictionaries: The following are checked "standard English USA, technical"
    • Options: The following are checked "Check spelling as you type, check grammar as you type, check uppercase words"
  5. Tools > Language > For Selection > English USA "is checked"

  6. Tools > Language > For Paragraph > English USA "won't let me check English USA"
  7. Tools > Language > For All Text > English USA "won't let me check English USA"

  8. Tools > LanguageTool > Check Text "this is checked"

Update: Trying to click (check) #6 and #7 makes the spell checker work again.

Does anyone know why when I click #6 and #7 a check does not appear in the box, but the spell checker starts working?