Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

calc suddenly runs very slowly

Running Version 5.3.1.2 on a reasonably modern Win 10 machine.

Very recently, data entry into a newly created calc spreadsheet has become very laggy. It takes a couple of seconds for each a cell to open to accept data. Newly entered data takes a few more seconds to appear in the cell. Moving to a new cell leaves the old cell blank for some some seconds before data reappears. Calculations that should be instant take a couple of seconds once the instruction has been entered.

Problem does not exist if I am editing an older existing spreadsheet. Even with old and new spreadsheets open in separate windows I am able to work normally on the old sheet and not the new. Seems to rule out computer problems.

I have tried both upgrading to 5.3.2 and uninstalling and reverting to 5.2.7/ I have tried renaming the App Data user file and seen a new one created. But the problem is persistent. Can anyone help sort it out please?

Any thoughts or guidance please?