Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problem with alternating different numbering and listing styles

Hi all, I'm using this great software since openoffice times, and as usual there more I use it there more I find new ways in doing things.

My last attemp was to build an written exam, since i lecture at an university. This template is composed of an heading, small title, date and numbered questions and non-numbered answers alternating (see bellow). The fun part comes now, in order not to have two arquives one only with questions and another with questions and answers I build to different styles containing two different ways of listing, one format for questions and another for answers, so that every time I hit return the new format is inserted and questions are continiously numberend in spite of intercalating answers, see example bellow.

  1. xxxxxxxxxx (question 1) "RETURN"

    R.: ccccccccc (answer to question 1 - after the previous RETURN the letter "R.:" are added automatically) "RETURN"

  2. xxxxxxxxxx (question 2 - after previous RETURN an question paragraph style is inserted again and numbering is added by one) "RETURN"

    R.: cccccccc (answer to question 2 - as with the previous one) "RETURN"

Up to here everything went fine. The reason why doing it this way, is because I can hide the "answer style paragraph" by modifying simply the character codition to hidden. This would allow me to hide all paragraphs containing answers while printing the questions.

The problem is while writting the exam. After I started inserting questions and answers if I deleted manually (with backspace or del) the last inserted answer or question and wanted to continue all my subsequent question number will be numbered taking into account the answer paragraph styles. After hitting return for an answer it inserts an R.: but after hitting return again it numbers the next question taking into account the answer paragraph, generating an non-continuous number list for questions. The only way I can correct this is creating an new archive and copying and pasting each paragraph with no formatting.

My question is how can the question style format keep numbering as previouslly after deleting one of the automatically formated paragraphs? Might this be an bug, in the sense that while deleting the text it deletes some hidden format command as well and so both paragraph styles are afterwards not being recognized as differente anymore?

Hope someone with more in deep LO knowledge could hepl me out here.