Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Highlighted black spaces?

I've noticed strange characters appearing in Writer documents that look like spaces higlighted black. They look just as regular spaces when seen in Page Preview, as opposed to the ones you would higlight manually which would show black in preview too.

They appeared several times, for instance, after copying text from web browser into Writer.

Anyone knows what they are and how to possibly prevent them from showing or is it a bug?

click to hide/show revision 2
retagged and added info based on manj_k's answer

Highlighted black spaces?

I've noticed strange characters appearing in Writer documents that look like spaces higlighted black. They look just as regular spaces when seen in Page Preview, as opposed to the ones you would higlight manually which would show black in preview too.

They appeared several times, for instance, after copying text from web browser into Writer.

Anyone knows what they are and how to possibly prevent them from showing or is it a bug?

EDIT: Thanks to @manj_k the solution is pinpointed. I looked up some additional info about non-breaking spaces:

Non-breaking spaces are not broken at the end of a line and are entered with the Ctrl+Shift+Spacebar shortcut keys.

To prevent two words from being separated at the end of a line, hold down the Ctrl key and the Shift key when you type a space between the words. In Calc, you cannot insert non-breaking spaces.

Non-breaking spaces are not used for hyphenation and are not expanded if the text is justified.

It's Unicode value is U+00A0 and it can be searched for in a document using \x00A0 provided regular expresions are enabled.

Highlighted black spaces?

I've noticed strange characters appearing in Writer documents that look like spaces higlighted black. They look just as regular spaces when seen in Page Preview, as opposed to the ones you would higlight manually which would show black in preview too.

They appeared several times, for instance, after copying text from web browser into Writer.

Anyone knows what they are and how to possibly prevent them from showing or is it a bug?

EDIT: Thanks to @manj_k the solution is pinpointed. I looked up some additional info about non-breaking spaces:

It's Unicode value is U+00A0 and it can be searched for in a document using \x00A0 provided regular expresions are enabled.