Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Fedora 22 upgrade, spell check not working

I have upgraded several systems to Fedora 22 (Libreoffice 4.4.5.2) and have now discovered that the auto spell checking is no longer working. That is, a misspelled word used to get a red squiggled line under it and produce suggestions on the correct spelling.

One suggestion that I have seen is to re-set the default language to "English (USA)". For some of the systems, this has worked and auto spell check is working, but on other systems this seems to not be working.

On the systems that are not working, the pull-down list showing all of the available languages shows an icon that looks like "ABC" and a check next to all of the english options EXCEPT for "English (USA)". On the systems that are working, this icon is present only on the "English (USA)". I interpret the icon to indicate that spell checking is available for these languages, and indeed, if I select "English (UK)" or any other choice with the icon, I do get auto spell checking.

I did see mention of installing "libreoffice-langpack-en". There were no language packs installed initially. After installing this, however, the situation has not changed.

So, the question is, how did I get all variations of English enabled for spell checking EXCEPT for USA, and, more importantly, how do I fix it?

Thanks!

marcus hall marcus@tuells.org

Fedora 22 upgrade, spell check not working

I have upgraded several systems to Fedora 22 (Libreoffice 4.4.5.2) and have now discovered that the auto spell checking is no longer working. That is, a misspelled word used to get a red squiggled line under it and produce suggestions on the correct spelling.

One suggestion that I have seen is to re-set the default language to "English (USA)". For some of the systems, this has worked and auto spell check is working, but on other systems this seems to not be working.

On the systems that are not working, the pull-down list showing all of the available languages shows an icon that looks like "ABC" and a check next to all of the english options EXCEPT for "English (USA)". On the systems that are working, this icon is present only on the "English (USA)". I interpret the icon to indicate that spell checking is available for these languages, and indeed, if I select "English (UK)" or any other choice with the icon, I do get auto spell checking.

I did see mention of installing "libreoffice-langpack-en". There were no language packs installed initially. After installing this, however, the situation has not changed.

So, the question is, how did I get all variations of English enabled for spell checking EXCEPT for USA, and, more importantly, how do I fix it?

Thanks!

marcus hall marcus@tuells.org

[Edit: added lo4.4.5 tag]

Fedora 22 upgrade, spell check not working

I have upgraded several systems to Fedora 22 (Libreoffice 4.4.5.2) and have now discovered that the auto spell checking is no longer working. That is, a misspelled word used to get a red squiggled line under it and produce suggestions on the correct spelling.

One suggestion that I have seen is to re-set the default language to "English (USA)". For some of the systems, this has worked and auto spell check is working, but on other systems this seems to not be working.

On the systems that are not working, the pull-down list showing all of the available languages shows an icon that looks like "ABC" and a check next to all of the english options EXCEPT for "English (USA)". On the systems that are working, this icon is present only on the "English (USA)". I interpret the icon to indicate that spell checking is available for these languages, and indeed, if I select "English (UK)" or any other choice with the icon, I do get auto spell checking.

I did see mention of installing "libreoffice-langpack-en". There were no language packs installed initially. After installing this, however, the situation has not changed.

So, the question is, how did I get all variations of English enabled for spell checking EXCEPT for USA, and, more importantly, how do I fix it?

Thanks!

marcus hall marcus@tuells.org

[Edit: added lo4.4.5 tag]