Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Libmwaw glitch?

I am trying to migrate an elderly friend to a new Mac. He has been using AppleWorks since forever, and now finally he is going to have to give it up. He has lots of AppleWorks documents floating around in his documents folder, and not all of them even have the correct file extension, since they date back to the Classic Mac OS days. Regardless, when I try to open any one of them in LibreOffice, I get "General error. General input/output error." This happens even when I open an empty text file. Most of these files are very simple in format, so the problem isn't that the mwaw filter is gagging on a difficult file to parse in terms of formatting. I checked: LibreOffice seems to be using libmwaw v 0.3.3; that is the glib included in the app. Any assistance in getting this unwedged would be greatly appreciated!

Libmwaw glitch?

I am trying to migrate an elderly friend to a new Mac. He has been using AppleWorks since forever, and now finally he is going to have to give it up. He has lots of AppleWorks documents floating around in his documents folder, and not all of them even have the correct file extension, since they date back to the Classic Mac OS days. Regardless, when I try to open any one of them in LibreOffice, I get "General error. General input/output error." This happens even when I open an empty text file. Most of these files are very simple in format, so the problem isn't that the mwaw filter is gagging on a difficult file to parse in terms of formatting. I checked: LibreOffice seems to be using libmwaw v 0.3.3; that is the glib included in the app. Any assistance in getting this unwedged would be greatly appreciated!

Libmwaw glitch?

I am trying to migrate an elderly friend to a new Mac. He has been using AppleWorks since forever, and now finally he is going to have to give it up. He has lots of AppleWorks documents floating around in his documents folder, and not all of them even have the correct file extension, since they date back to the Classic Mac OS days. Regardless, when I try to open any one of them in LibreOffice, I get "General error. General input/output error." This happens even when I open an empty text file. Most of these files are very simple in format, so the problem isn't that the mwaw filter is gagging on a difficult file to parse in terms of formatting. I checked: LibreOffice seems to be using libmwaw v 0.3.3; that is the glib included in the app. Any assistance in getting this unwedged would be greatly appreciated!